Support » Plugin: W3 Total Cache » W3 Total CACHE restapi problem

  • Resolved fedan80

    (@fedan80)


    Hi,
    When I active the plugin, it’s not possibile to update the products with woocommerce API.
    Also other API function doesn’t work.
    The plugin delete the Header data.
    could it be Object Cache? The Object Cache Method is MEMCACHED
    Can I solve this conflict?
    Waiting for reply
    Regards

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    In Performance>Page cache is REST API set to cache or Don’t cache? If so, select Disable REST API, save all settings and see if the issue persists.

    Thread Starter fedan80

    (@fedan80)

    If I select disable REST API, the API doesn’t work.
    The get call API work correctly.
    The put call API doens’t work.

    The result is ok but the update isn’t apply.

    Waiting for reply

    Kind Regards

    Thread Starter fedan80

    (@fedan80)

    Hi,

    In the plugin I dont’t found, in PAGE CACHE, Reject HEAD requests.

    I’ve to disable this option.

    Waiting for reply

    Kind Regards

    Thread Starter fedan80

    (@fedan80)

    Hi,
    there are news for my request?

    Kind regards

    Thread Starter fedan80

    (@fedan80)

    Hi,

    I need to exclude from the cache JSON API in order to update the product

    Waiting for reply

    Kind regards

    Thread Starter fedan80

    (@fedan80)

    Hi,

    When I active PAGE CACHE on the plugin, the woocommerce JSON API doens’t work correctly.

    I have also set “REST API” on Don’t Cache.

    Can I Solve the problem?

    Regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    There are a couple of things that you should follow in order to W3 Total Cache and Woocomerce work together.
    1. Exclude WooCommerce Pages from Caching (Woocmmerce sets the DONOTCACHEPAGE, constant to their pages but you should confirm that)
    2. Add mfunc in ignored comments stems for HTML minification. In Performance>Minify add mfunc to “Ignored comment stems” text box under “HTML & XML” section.
    3. Exclude Woocomerce JS and CSS files from being minified or use Manual minify and add JS and CSS files manually, excluding the Woocommerce files.
    4. Add all WooCommerce pages for not minifying. Add those files in Performance>Minify, “Never minify following pages” text area. This step is optional and should be performed only if required due to the setup.
    5. Add _wc_session_ in “ignored query stems” field in Performance>Database Cache, Advanced sub-box

    Thread Starter fedan80

    (@fedan80)

    Hi,

    I try those settings but the product update via JSON API doens’t work.

    It works if I disable PAGE CACHE setting.

    Waiting for reply

    Kind Regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    What caching method are you using?

    Thread Starter fedan80

    (@fedan80)

    Hi,

    I use MEMCACHED. I already tried with DISK:ENANCHED

    Waiting for reply

    Kind Regards

    • This reply was modified 1 year, 9 months ago by fedan80.
    Thread Starter fedan80

    (@fedan80)

    Do you have news for my request?
    With page cache activated, it’s not possible to use the PUT method with the API in order to update the products on my website
    Waiting for reply
    Kind regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    If you have excluded those pages from being cached and minified everything should work as expected.
    It appears that you have some other issues on your end. I can offer you Pro support to investigate this.

    Thread Starter fedan80

    (@fedan80)

    In the section “Never cache the following pages:”

    I’ve only:

    wp-.*\.php
    index\.php

    I’ve to insert other pages?

    Waiting for reply

    Kind Regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    I.E.
    /page/
    /shop/
    /cart/
    /product/

    Thread Starter fedan80

    (@fedan80)

    My website is in Italian language.

    I’ve to check the correct permalink?

    Waiting for reply

    regards

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘W3 Total CACHE restapi problem’ is closed to new replies.