Support » Plugins » W3 Total Cache – Pages Don't GZip or Cache

  • Pages aren’t GZipped and cached.
    I can’t seem to resolve this.

    For example, Webpagetest reports:
    GZIP encode all appropriate text assets: 53/100
    144.3 KB total in compressible text, target size = 76.9 KB – potential savings = 67.4 KB
    FAILED – (81.4 KB, compressed = 14.0 KB – savings of 67.4 KB) –

    I have the obvious cache + compression settings ticked in W3 Total Cache.
    BTW: I am using the Suffusion theme with the suggested setting of: “Don’t auto-generate the CSS, and print it in the HTML source “

    Over a week of tuning W3 Total Cache has improved many things, but this is stumping me. I have done endless web-searching as well.
    Any insights appreciated.

    Page Cache Debug info:

    <!– W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Cache key: _index.html
    Caching: enabled
    Status: not cached
    Creation Time: 0.963s
    Header info:
    Content-Type: text/html; charset=UTF-8
    X-Powered-By: W3 Total Cache/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Reset to defaults didn’t help.

    Uninstalling, removing all associated files, reinstalling doesn’t help.

    In fact, just installing W3tc makes my page Time to First Byte increase considerably regardless of settings.

    Some of the threads about related issues are simply resolved, but some of those threads just stop, so no resolution?

    Am I missing something obvious?
    Something obscure?
    Known issue?


    Chris Olbekson


    Level 12 Bug Squasher & Forum Moderator

    Your pages are being cached. Did you log out or visit from a browser with cleared cookies before checking?

    <!– Performance optimized by W3 Total Cache. Learn more:
    Minified using disk
    Page Caching using disk
    Database Caching 48/72 queries in 0.353 seconds using disk
    Content Delivery Network via Rackspace Cloud Files:

    Your html, js and css are being gzipped. See response headers below:

    Response Headers
    Cache-Control:max-age=31536000, public, must-revalidate, proxy-revalidate
    Content-Type:application/x-javascript; charset=utf-8
    Date:Fri, 12 Aug 2011 10:19:34 GMT
    Expires:Sat, 11 Aug 2012 10:19:34 GMT
    Last-Modified:Wed, 10 Aug 2011 07:34:40 GMT
    X-Powered-By:W3 Total Cache/

    Also turn off database disk caching it’s probably slowing your site down.

    Hi, thanks for the reply.

    I was using logged out browsers on different systems, with browsers cleared.
    Also, used webpagetest, loadimpact, tools.pingdom, pagespeed in FF5, ySlow in FF5, and through W3tc (in Dashboard) to verify results.

    All were showing the pages as not compressed as I just got now:
    from webpagetest : GZIP encode all appropriate text assets: 53/100
    144.1 KB total in compressible text, target size = 76.9 KB – potential savings = 67.1 KB
    FAILED – (81.1 KB, compressed = 13.9 KB – savings of 67.1 KB) –

    I spent the entire day yesterday dealing with this. ( 6:30am-2:30am ! )
    I was able to achieve sometime compression, you caught it when it was working.

    I opened a CDN at Rackspace, created a container and uploaded all files, as in the FAQ, with no errors or failed transfers, nothing in the queue.
    When the CDN was enabled several files on every page were not being served to the site.
    Rackspace support couldn’t resolve this.
    I created another container and again uploaded the files with no problems, but some files were still not being served.
    If I disabled the CDN on the General Settings page, the entire site, including the ‘missing’ files, loaded fine,
    but with no page compression. So, enabling the CDN in W3tc somehow stopped these files from being loaded.

    I tried every combo of settings I could think of, testing with the above tools all the way.
    I saved out the W3tc settings when there was a significant change.

    I discovered several points:

    *If I used Database Caching to Disk, I got slightly better load times, as I did with Page Cache set to Disk (basic) rather than (enhanced)

    *If I enabled the CDN, at times, I eventually got the pages to GZip !!! (not sure exactly how, though) but with files missing on every page.

    *If I had CDN enabled, but disabled Host Attachments on the Content Delivery Network page, I could get all the site files to load,
    and at some point in my testing, I got the pages to GZip as well!!!

    So then I tried this multiple times with the above tools and found that this partial implementaion of the CDN,
    combined with my other settings gave me better download speeds, and occasional Page GZipping,
    I discovered that all of my internal posts were now returning 404 errors, not Pages, but ALL OF THE POSTS, and Category PAGES.

    I spent the latter part of the night working on this.
    What ended helping was uninstalling W3tc and associated files, uninstalling Redirection,
    recreating my .htaccess from an earlier version, and finally updating my Permalinks, and importing W3tc settings from a backup.

    This still leaves me with only partial CDN implementation, and my pages are not showing as Gzipped this morning.

    Sorry for the long post here, but it’s hard to sum up 20 hours of testing results without details 😉

    So, what to do know?

    The pages are now sometimes GZipped but not always.

    I will find that there are intermittent problems with:
    page compression
    one W3tc css file ”
    and one W3tc js file ”

    Sometimes a test shows all ok
    sometimes the page is not compressed
    sometimes the css file is not compressed, or fails to load properly
    somtimes it’s the js that isn’t compressed or fails to load properly.

    I get occassional Minify Error notices, sometimes singly, sometimes in pairs at the same time.
    I’m guessing that when one or two minify errors occur, there is resulting problems with these files.

    Is there anything in this Minify Debug info that would help pin this down?

    <!– W3 Total Cache: Minify debug info:
    Engine: disk
    Theme: 90991
    Template: index

    Replaced CSS files:
    1. wp-includes/css/admin-bar.css
    2. wp-content/themes/suffusion/style.css
    3. wp-content/themes/suffusion/skins/light-theme-royal-blue/skin.css
    4. wp-content/themes/suffusion/dark-style.css
    5. wp-content/themes/suffusion/skins/dark-theme-royal-blue/skin.css
    6. wp-content/themes/suffusion/rounded-corners.css
    7. wp-content/plugins/quotes-collection/quotes-collection.css

    Replaced JavaScript files:
    1. wp-includes/js/l10n.js
    2. wp-includes/js/jquery/jquery.js
    3. wp-content/plugins/quotes-collection/quotes-collection.js
    4. wp-content/themes/suffusion/scripts/suffusion.js
    5. wp-includes/js/admin-bar.js
    <!– Performance optimized by W3 Total Cache. Learn more:


    Perhaps this is related to this thread?

    Hey Ken. Did you ever get these issues resolved? They sound a lot like what I’m going through. W3TC is working well for me, except that gzip is very unpredictable. Sometimes it works, sometimes it doesn’t.

    Hi Ira,

    After much work on this, I disabled and deleted the plugin, and continued to work on the site.

    I reinstalled the plugin and was able to get it working, mostly.
    I’m running 9.2.4

    I still get times when things don’t work, but I never found a pattern.

    Sorry for the trouble Ken, if you have more details I’m interested.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘W3 Total Cache – Pages Don't GZip or Cache’ is closed to new replies.