Support » Plugin: W3 Total Cache » W3 Total Cache on a Subdomain

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Frederick Townes

    (@fredericktownes)

    A TLD domain is domain.com and a sub-domain is normally sub.domain.com. Are you you using multi-site?

    I mean with the webhoster.

    The main website is located in the public_html and the subdomains are like this in directory: public_html/subdomainname.com.

    In the main .htaccess (which is locatad in public_html) are the rules for the subdomains written like this to work correct:

    #RULE:,subdomainname.com,/subdomainname.com
    RewriteCond %{HTTP_HOST} ^www.subdomainname$
    RewriteCond %{REQUEST_URI} !^/subdomainname.com/

    Maybe I can send you a pm for the website.

    Thanks Frederick Townes!

    I made a mistake.

    The website is on a subdirectory of the server. W3TC doenst work on a subdirectory.

    Has anybody a solution for websites which are located in a subdirectory on the sever with W3TC?

    Plugin Author Frederick Townes

    (@fredericktownes)

    @mari_d, would you mind submitting a bug submission form from the support tab of the plugin so I can see what’s going on with your install?

    kioub

    (@kioub)

    Hello Frederick, all

    I am experiencing the exact same problem. I have been using W3 Total cache for all of my WordPress based sites without any problems until I started using it on WordPress installations for subdomain sites.

    I use ServInt as my hosting provider and a subdomain WordPress site is realized as a folder inside my “public_html” folder – where all of the main site’s WordPress files reside.

    I have applied the exact same configuration for W3 Total cache on both the primary and subdomain sites and allthough cache on the main site is working as expected, on the subdomain sites the following two error messages appear :

    – It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    – It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    After “playing” with the configuration I managed to get rid of the errors by setting options on Page cache to “Disk:Basic” (it was set on “Disk:Enhanced) and Minify to disable “Rewrite URL structure”. The cache actually appeared to be working, even with the errors I saw in the admin panel.

    I forwarded the issue to ServInt support team that checked the configuration on both the main and subdomain sites but could not figure out the real cause of the problem. They said that it looks like there is a bug with W3TC and not a problem with your server pointing to the following thread of the W3 total cache forum :

    http://wordpress.org/support/topic/page-cache-url-rewriting-is-not-working

    Unfortunately posts on the forum does not shed any more light for resolving the specific issue. In addition since the specific errors are present I am not able to deploy minified files on CDN.

    Does anyone is experiencing the same problems?

    I have tested the specific setup on WordPress versions 3.4.2 up to 3.5.1 (including)

    I would really appreciate your feedback. At your disposal for further input.

    Thanks in advance

    Byron

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘W3 Total Cache on a Subdomain’ is closed to new replies.