WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache no gzip?

W3 Total Cache no gzip?

  • I’ve gone back to W3 Total Cache.

    I get an ‘F’ from Yslow on compress components with Gzip. I’ve tried both ‘Gzip and deflate’ and just ‘gzip’ in the page cache settings with the same result.

    What can I do to get gzip to work for page caching with W3 total cache? I’ve seen old unresolved threads of this elsewhere…

    Also, I get the following error for caching:

    “The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources….”

    Is there a way to resolve the lack of ETag headers for the long list of files?

Viewing 1 replies (of 1 total)
  • If you look closely you will see that you’re failing for files other than your pages. You need to take advantage of the file found in: wp-content/plugins/w3-total-cache/ini/_htaccess which is commented and will help you with the rules to optimize your other files. This will be implemented automatically in a future release.

    I would also guess that you’re not minifying many files that should be.

Viewing 1 replies (of 1 total)
  • The topic ‘W3 Total Cache no gzip?’ is closed to new replies.
Skip to toolbar