Support » Plugins » W3 Total Cache Installation – Page Caching not Available

  • Resolved Trout7000


    I have been running WP Super Cache on my blog I recently removed the Super Cache plugin and I installed W3 Total Cache. I got a warnig which says that page caching is unavailable and I am instructed to add code: define(‘WP_Cache’,true); to my wp-config.php file. But his line of code is already there on my config.php file. I don’t know why the plugin does not see this line.

    I am not a tech professional and I would appreciate any suggestions.

Viewing 7 replies - 1 through 7 (of 7 total)
  • @Trout7000- The new code is different. Replace the old with the new and you should be good to go.


    Thank you for your response. The code which is requested by the error flag is identical with the code already present on the config.pgp file.

    define(“WP_CACHE’, true);

    Forgive me for causing confusion if I did not type the code perfectly in my original post. I’m running the current version of WordPress and I’m installing current version of Total Cache. I’m still at a loss.

    @Trout7000- Are you sure? Did you eyeball every character and every word? Did you try replacing it with the new code just in case you missed something? Are you placing the code in the correct directory?


    First, thank you for your attention. This is my first experience with the forum and I am as grateful as can be for your help.

    The wp-onfig.pgp file, when I examined it, contained as its third line of code:

    //define(‘WP_CACHE’, true); //Added by WP-Cache Manager

    I deleted this line and re-inserted the code required by W3 Total Cache:

    define(‘WP_CACHE’, true);

    When i saved this change, the code was automatically converted to the former and the error flag persisted.

    I again deleted this third line of code in my wp-config.pgp file and I inserted the code on the last line of that file. Both lines of code were automatically restored and now I have the full code on both the third and the last line of the pgp file. Of course, the error message persists. There is no other file “wp-config.pgp” in my ftp site folder.

    Thank you for your patience with this member who has limited experience and tech capabilities. I am skeptical of the assertion that “CODE IS POETRY.”

    @Trout7000- I’m not a coder either. I can only tell you what I do when W3TC gives me code to be placed in a given directory. I delete all code for the previous entry (page cache, browser cache, or whatever it may be) entirely and paste the new code in its place. I do not tamper with it line by line or try to modify the old item. I delete it and replace it then hit refresh on the WP page and all is well.


    Success! Thank you!!!

    I was using a Network Associate (my hosting server) tool for access to my ftp files. By copying and downloading to my desktop, editing on my desktop, deleting from my ftp folder, and finally uploading back to the ftp site, I was able to finally correct the code.

    Thank you for your continued patience, advice and inspiration.

    I’m glad it worked out.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘W3 Total Cache Installation – Page Caching not Available’ is closed to new replies.