Support » How-To and Troubleshooting » [Resolved] W3 Total Cache – FTP Self Hosted CDN Option – Can’t Get it to Work

[Resolved] W3 Total Cache – FTP Self Hosted CDN Option – Can’t Get it to Work

  • I must be missing something simple. No matter how I configure it, the test always fails.

    Can somebody walk me through this? And can ya make it idiot proof for this idiot? :))

    Use passive FTP mode – to check or not to check…that is the question

    FTP hostname: – I am using the same shared hosting server as my site – do I use localhost or http://ftp.mydomain.com?

    FTP username: I created a new one just for this purpose

    FTP password: I created a new one just for this purpose

    FTP path: Is this a server path, an html one or an ftp. one?

    Replace site’s hostname with: I created a subdomain called CDN.mydomain.com and it points to a folder called /CDN – I created an FTP login that strictly has access to only that folder. I also tried to give the login full access, but that did not work neither.

    Any help would be greatly appreciated.


Viewing 15 replies - 16 through 30 (of 33 total)
  • Hi

    I use WP 2.9.2 and the WP shoppingcart plugin
    I just installed the W3tc plugin and after activating CDN and uploading all the files i now have some issues:
    – mainpage is gone
    – pictures are gone
    – text in posts is doubled
    – my navigation is messed up ( missing the + and – signs )

    My website is http://www.landyspecials.com

    Can you help me please?

    Gr, Rob van Abeelen

    For now disable CDN. Then submit a bug submission via the support tab.

    Hello I am having the same issue as the original poster. To give you a bit of details.

    My host is Hostgator, on a shared hosting account. The domain where I have the plugin installed is an addon domain in my account, I also created the subdomain as cdn.mydomain.com

    I created the ftp account to be separate from my main one and I can connect to cdn.mydomain.com without a problem and browse directories, upload files, etc.

    Additionally I can access a simple text file via the browser, also the dns has propagated, without me doing anything, I guess the hosting company does that when adding subdomains automatically. I checked this with whatsmydns.net added cdn.mydomain.com and responses where fine.

    I also copied and checked the .htaccess file in the wp-content/plugins/w3-total-cache/ini/_htaccess and of course renamed it to .htaccess into the root of cdn.mydomain.com

    I enabled the cdn in the plugin, copied all the settings from my ftp client to the fields in the plugin, for troubleshooting I checked different combinations of ftp passive mode on and off, with ftp path and without, login in via the main ftp account and the one created specifically for cdn.mydomain.com and each time it says testing… I left it overnight and no change.

    I also followed the instructions at http://www.strictlyonlinebiz.com/blog/speed-up-wordpress-with-w3-total-cache/1231/ as they matched my host and still wouldn’t work.

    Any other suggestions? And thank you in advance for any help.


    I have exactly the same problem trying to get W3TC to work with CDN at VPS.NET as you know Frederick. Is there something you can see that might be common to all of us having this problem?

    Anyone that has not submitted a bug submission form from the support tab of the plugin, please do so.

    Only problem is your bug report form doesn’t work.

    Outbound Email is disabled for security reasons on my server.

    Then you can email me directly.

    Hi, when I try to upload via admin panel FTP the plugin always show Failing Upload but the file are uploaded.

    The test ftp always show testing.

    What does it mean ?


    There can be JS issues here. Trying the development version would be helpful to me to put this issue to rest.

    Hello Fredericktownes,

    I went ahead and installed the dev version of the plugin and that solved the “Testing” issue with the cdn.

    Everything is working like a charm. Plus all the new features added makes this a solid choice for anyone.

    Thanks for your development time and effort.


    You’re welcome.

    I’m having the same ‘testing’ issues.

    It use to work fine before WordPress 3, so I’m wondering if it’s not a new conflict.

    Eagerly awaiting a new version. 🙂

    You’re using the development version?

    Thanks Fredrick for the fix,yea was having the same problems with the upload error too.

    For other users I’m using a a Hostgator VPS Linux dedicated server and created a subdomain named static.yourdomainhereexample.com.

    I was plagued with the upload errors and failed ftp test. I simply updated to the development version of W3 Total Cache found here at the W3 Total Cache Development Version Download Page and it fixed all the problems.


    Signing off Scot Manaher ~

    You’re welcome @scotman.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘[Resolved] W3 Total Cache – FTP Self Hosted CDN Option – Can’t Get it to Work’ is closed to new replies.