Support » Fixing WordPress » W3 Total Cache – FTP Self Hosted CDN Option – Can’t Get it to Work

  • Resolved rashadow

    (@rashadow)


    I must be missing something simple. No matter how I configure it, the test always fails.

    Can somebody walk me through this? And can ya make it idiot proof for this idiot? :))

    Use passive FTP mode – to check or not to check…that is the question

    FTP hostname: – I am using the same shared hosting server as my site – do I use localhost or http://ftp.mydomain.com?

    FTP username: I created a new one just for this purpose

    FTP password: I created a new one just for this purpose

    FTP path: Is this a server path, an html one or an ftp. one?

    Replace site’s hostname with: I created a subdomain called CDN.mydomain.com and it points to a folder called /CDN – I created an FTP login that strictly has access to only that folder. I also tried to give the login full access, but that did not work neither.

    Any help would be greatly appreciated.

    http://silenciobarnes.com
    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 33 total)
  • For self hosted:

    1. Be sure to use the file found in wp-content/plugins/w3-total-cache/ini/_htaccess in the document root of your subdomain. Rename it and read the comments there to be sure that all is the way you want/need it.

    2. Simply create a subdomain, DNS and then test the FTP settings with a FTP client making sure files you upload are available in your browser, then copy those settings to W3TC. This is in the FAQ. Many FTP servers have nuances that I cannot possibly provide documentation for. So start here. Use localhost or 127.0.0.1 for hostname for uploading if possible

    I have exactly the same issue (shared hosting, subdomain, new FTP user).
    Even testing FTP server from CDN settings page is stuck forever.

    I tried ftp username and password from bash and FTP client and it works fine. Subdomain is also configured.

    127.0.0.1 or domain name doesn’t solve at all.

    I wonder if it “sanitize” username and password (I have @ and *).

    BTW, where’s the log for this plugin?
    I don’t see any error in error_log or admin/error_log so I wonder if there’s another place.

    It seems that I have the same problem as the person on this thread: http://wordpress.org/support/topic/391367

    @j2l – These instructions here may help you: http://wordpress.org/support/topic/302341

    When I put 127.0.0.1 and path is local I have CDN activated once, then on reload it’s no more there.

    Where’s the log?

    cURL seems to be partially working on my shared host, it’s there according to phpinfo() but FTP testing is stuck.

    I checked about curl, it’s ON and working and detected by W3.
    There’s no log files at all, I won’t ask again 🙂

    The only solution I see is that I send files, via FTP to CDN, manually.

    Can anyone can try CDN with FTP and get back with details for me?

    Simply tell me the directory structure of files once on CDN (folders, sub-folders, files locations within this folders, …).
    Thanks.

    I guess it’s something like:

    /wp-includes
    -files
    /wp-content
    -/theme
    –/mytheme
    —files
    min css file
    min js file
    custom files

    Please confirm 🙂

    All that’s left is debugging on your server. Please submit a bug submission report from the support tab of the plugin.

    Try the instructions I left @ http://www.strictlyonlinebiz.com/blog/speed-up-wordpress-with-w3-total-cache/1231/ and see if that helps

    If your main site is http://www.website.com use your main ftp which should be http://ftp.website.com. If you subdomain is cdn.website.com and this is pointing @ public_html/cdn, then you must use public_html/cdn as your directory under cdn settings

    I meant ftp(dot)website(dot)com not http://ftp.website.com

    @strictlyonlinebiz – that’s a nice, straightforward tutorial that you put together. Unfortunately, the CDN option still doesn’t work – I learned to live without it 🙁

    My host doesn’t use public_html – my root looks something like (fatcow hosting) /home/users/web/***/moo.username/CDN – but even with that, it fails. Oddly, when it says that it is trying to upload a test file into the wp uploads, it always says it fails…but the test files actually do make it into the upload folder when I check via ftp – and yea, using an ftp client works fine.

    @rashadow: Thanks for the compliments. If the files are getting uploaded, despite test failed messages, I suggest you just leave it (the configuration) be that way.

    @fredericktownes: is there a problem with the plug-in recognizing paths such as rashadows’?

    No there’s not. I’d have to debug on his server to find the nuance.

    I’m not too concerned with it. After all, wordpress 3.0 is about to drop any day now and that means there’s probably a new release of W3TC coming as well. Figured I’d wait for both of those and then tackle the problem fresh 🙂

    Ok.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘W3 Total Cache – FTP Self Hosted CDN Option – Can’t Get it to Work’ is closed to new replies.