WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » W3 Total Cache error Page Cache URL rewriting

W3 Total Cache error Page Cache URL rewriting

  • I got the following error:
    W3 Total Cache error: It appears Page Cache URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately disk enhanced page caching will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.
    Technical info

    Is there anything i can do through cPanel?

    thanks

    http://wordpress.org/plugins/w3-total-cache/

Viewing 4 replies - 1 through 4 (of 4 total)
  • bump, getting the same error, recently.

    Many webhosts don’t make Enhanced Disk Caching available in certain hosting environments, ie Shared Hosting or Managed WP Hosting. VPS or Dedicated may afford additional opportunities.

    First, contact your host at make it’s available. If it is, they can install it for you to the server (if you have managed hosting.)

    If not, you can see if an OpCode cache is available, or you will have to use Basic Caching.

    I have the W3 installed in 5 websites. In one of them, the site works fine from any browser, but when I’m trying to access it through a “page loading test” site (e.x. pingdom.com, websiteoptimization.com, uptimerobot.com) the site always reports Forbidden 403 error!

    When I change on “Page Cache Method” from “Disk: Enhanced” to “Disk: Basic” the 403 Error stopped showing up.

    Any idea to enable “Disk: Enhanced” and stop with the Forbidden 403 Error?

    Just an update to help someone having the same issue… I’ve fixed the problem following the steps below 🙂

    In public_html/wp-content/cache/page_enhanced/www.mysite.com there were 2 files, _index.html.old and _index.html_gzip.old. There was also a public_html/wp-content/cache/page_enhanced/www.mysite.com/.htaccess folder and inside it there were 2 files, _index.html and _index.html_gzip.

    So I renamed .htaccess folder to .htaccess_old and also the files inside to _index.html.old and _index.html_gzip.old.

    Then I renamed the _index.html.old and _index.html_gzip.old from inside public_html/wp-content/cache/page_enhanced/www.mysite.com to _index.html and _index.html_gzip.

    So the problem was fixed and I was able to enable page cache disk enhanced mode.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘W3 Total Cache error Page Cache URL rewriting’ is closed to new replies.
Skip to toolbar