WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » W3 total cache error: incorrect # BEGIN W3TC Page Cache message

W3 total cache error: incorrect # BEGIN W3TC Page Cache message

  • I’m receiving the following error in the Performance Dashboard:
    Edit file /var/www/XXXXXX/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    I have the new # BEGIN W3TC Page Cache core rules in place and have completely removed the old page cache rules, but continue to receive this message. I am editing the correct .htaccess file.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 20 total)
  • Same here. I’m W3TC 0.9.2.11.

    I assume it just looks for the “W3TC Page Cache” string… I tried giving it a different section name but then it of course complains because “W3TC Page Cache core” is missing.

    I encountered the same problem with version 0.9.2.10 but upgrading to version 0.9.2.11 resolved the issue for me. I’m thinking it searches the htaccess file for “W3TC Page Cache” and finds a hit on “W3TC Page Cache core” and generates the message. I’m not sure why it’s no longer happening for me.

    I did submit a bug report on this so the author is aware of this issue.

    Peace…

    I did submit a bug report on this so the author is aware of this issue.

    Fine, but the two ain’t necessarily the same 😉

    You may have submitted a bug report (where?) but the author may still not be aware of it. Just as only ~10% of all the W3TC threads here are answered/replied to: “44 of 432 support threads in the last two months have been resolved.”

    I submitted the bug report from within the plugin, itself. There’s a “Support” link I used to report the issue. I’m confident the plugin author is aware of this specific issue because Mr Townes responded to my bug report via e-mail and asked for more information. 🙂

    I don’t know if Mr Townes did any investigation into the issue since I told him the upgrade to W3TC 0.9.2.11 addressed the issue but at least her responded to my bug report.

    So, if you haven’t filed a bug report yet, you might want to consider doing so. Or, maybe he’ll see this thread and take another look at the bug report I filed.

    Peace…

    Same here with W3TC 0.9.2.11. 🙁
    I hope it will be fixed.

    Plugin Author Frederick Townes

    @fredericktownes

    You need to check your error.log file should be available by your host. It should contain error message about what has caused the 500 error message.

    I just got an email from this forum with a comment that is not listed here. Odd…here it is:

    Please check which files are supposed to be edited. The core rules goes into wp-content/cache/page_cache/.htaccess the other rules goes into the XXXXXX/.htaccess file.

    I don’t have a wp-content/cache/page_cache/.htaccess file. I don’t even have a page_cache folder but I have a wp-content/cache/page folder. Should I create a .htaccess file in that folder manually?

    If I disable the page cache the plugin tells me

    Edit file XXX/public_html/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache core and # END W3TC Page Cache core markers.

    which is quite different from the statement above. Totally puzzled now…

    Plugin Author Frederick Townes

    @fredericktownes

    Check which files are supposed to be edited. The core rules goes into wp-content/cache/page_cache/.htaccess the other rules goes into the XXXXXX/.htaccess file.

    Ah, looks like this forum sent out the email before the posted showed up here? Please see my reply above.

    The message says:

    Edit file /XXXXXX/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    But the .htaccess File in XXXXXX does not contain this string! There is only this string:

    # BEGIN W3TC Page Cache core

    # END W3TC Page Cache core

    I also have no path wp-content/cache/page_cache/.htaccess, only wp-content/cache/page_enhanced/.htaccess. And there is only this string:

    # BEGIN W3TC Page Cache cache

    # END W3TC Page Cache cache

    I’ve tried everything, still get the message. 🙁
    What to do?

    BTW: I have a htpasswd-protection (it’s a test-site), does it have to do with it?

    Still need Help. 🙁
    With version 0.9.2.9 everything is good, but I want to update!

    I know my english is bad. But that does not mean that I have something configured incorrectly. I’m really a WordPress-pro, but I can not solve this problem. Can you please show me a direction?

    Plugin Author Frederick Townes

    @fredericktownes

    Please submit a bug submission form from the support tab of the plugin or an email through the form on our website.

    I have exactly the same issue that sms-producer… any hint about how to solve it? cheers

    W3 Total Cache 0.9.3 addresses this issue. Additionally, I’ve sent a patch which also addresses this issue. I’m running with my patch and this problem is resolved. So, try upgrading to W3 Total Cache 0.9.3 first and if the problem isn’t resolved, we can talk about my patch.

    Peace…

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘W3 total cache error: incorrect # BEGIN W3TC Page Cache message’ is closed to new replies.
Skip to toolbar