WordPress.org

Forums

W3 Total Cache
W3 total cache error: incorrect # BEGIN W3TC Page Cache message (21 posts)

  1. jesseoverright
    Member
    Posted 2 years ago #

    I'm receiving the following error in the Performance Dashboard:
    Edit file /var/www/XXXXXX/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    I have the new # BEGIN W3TC Page Cache core rules in place and have completely removed the old page cache rules, but continue to receive this message. I am editing the correct .htaccess file.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. marcelstoer
    Member
    Posted 2 years ago #

    Same here. I'm W3TC 0.9.2.11.

    I assume it just looks for the "W3TC Page Cache" string... I tried giving it a different section name but then it of course complains because "W3TC Page Cache core" is missing.

  3. tomdkat
    Member
    Posted 2 years ago #

    I encountered the same problem with version 0.9.2.10 but upgrading to version 0.9.2.11 resolved the issue for me. I'm thinking it searches the htaccess file for "W3TC Page Cache" and finds a hit on "W3TC Page Cache core" and generates the message. I'm not sure why it's no longer happening for me.

    I did submit a bug report on this so the author is aware of this issue.

    Peace...

  4. marcelstoer
    Member
    Posted 2 years ago #

    I did submit a bug report on this so the author is aware of this issue.

    Fine, but the two ain't necessarily the same ;-)

    You may have submitted a bug report (where?) but the author may still not be aware of it. Just as only ~10% of all the W3TC threads here are answered/replied to: "44 of 432 support threads in the last two months have been resolved."

  5. tomdkat
    Member
    Posted 2 years ago #

    I submitted the bug report from within the plugin, itself. There's a "Support" link I used to report the issue. I'm confident the plugin author is aware of this specific issue because Mr Townes responded to my bug report via e-mail and asked for more information. :)

    I don't know if Mr Townes did any investigation into the issue since I told him the upgrade to W3TC 0.9.2.11 addressed the issue but at least her responded to my bug report.

    So, if you haven't filed a bug report yet, you might want to consider doing so. Or, maybe he'll see this thread and take another look at the bug report I filed.

    Peace...

  6. sms-producer
    Member
    Posted 2 years ago #

    Same here with W3TC 0.9.2.11. :-(
    I hope it will be fixed.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    You need to check your error.log file should be available by your host. It should contain error message about what has caused the 500 error message.

  8. marcelstoer
    Member
    Posted 2 years ago #

    I just got an email from this forum with a comment that is not listed here. Odd...here it is:

    Please check which files are supposed to be edited. The core rules goes into wp-content/cache/page_cache/.htaccess the other rules goes into the XXXXXX/.htaccess file.

    I don't have a wp-content/cache/page_cache/.htaccess file. I don't even have a page_cache folder but I have a wp-content/cache/page folder. Should I create a .htaccess file in that folder manually?

    If I disable the page cache the plugin tells me

    Edit file XXX/public_html/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache core and # END W3TC Page Cache core markers.

    which is quite different from the statement above. Totally puzzled now...

  9. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Check which files are supposed to be edited. The core rules goes into wp-content/cache/page_cache/.htaccess the other rules goes into the XXXXXX/.htaccess file.

  10. marcelstoer
    Member
    Posted 2 years ago #

    Ah, looks like this forum sent out the email before the posted showed up here? Please see my reply above.

  11. sms-producer
    Member
    Posted 2 years ago #

    The message says:

    Edit file /XXXXXX/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    But the .htaccess File in XXXXXX does not contain this string! There is only this string:

    # BEGIN W3TC Page Cache core
    ...
    # END W3TC Page Cache core

    I also have no path wp-content/cache/page_cache/.htaccess, only wp-content/cache/page_enhanced/.htaccess. And there is only this string:

    # BEGIN W3TC Page Cache cache
    ...
    # END W3TC Page Cache cache

    I've tried everything, still get the message. :-(
    What to do?

    BTW: I have a htpasswd-protection (it's a test-site), does it have to do with it?

  12. sms-producer
    Member
    Posted 2 years ago #

    Still need Help. :-(
    With version 0.9.2.9 everything is good, but I want to update!

  13. sms-producer
    Member
    Posted 2 years ago #

    I know my english is bad. But that does not mean that I have something configured incorrectly. I'm really a WordPress-pro, but I can not solve this problem. Can you please show me a direction?

  14. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Please submit a bug submission form from the support tab of the plugin or an email through the form on our website.

  15. jvarela
    Member
    Posted 1 year ago #

    I have exactly the same issue that sms-producer... any hint about how to solve it? cheers

  16. tomdkat
    Member
    Posted 1 year ago #

    W3 Total Cache 0.9.3 addresses this issue. Additionally, I've sent a patch which also addresses this issue. I'm running with my patch and this problem is resolved. So, try upgrading to W3 Total Cache 0.9.3 first and if the problem isn't resolved, we can talk about my patch.

    Peace...

  17. FranH
    Member
    Posted 1 year ago #

    Had the same issue with 0.9.3

    Resolved it my removing Rules added by Better WP Security plugin, refreshing WP admin page and returning the Better WP Security rules back (reload .htaccess file, of course)

  18. ChrisZee
    Member
    Posted 1 year ago #

    I tried to send support email through the plugin, but says You do not have sufficient permissions to access this page.

    this is the error I get:

    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.
    Please execute commands manually
    or use FTP form to allow W3 Total Cache make it automatically.
    Edit file /home/wwwchri/public_html/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    W3 Total Cache error:It appears Minify URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately minification will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.

  19. daevid
    Member
    Posted 1 year ago #

    I have the same problem with 0.9.3.

    Any news on this?

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    @daevid: As per the Forum Welcome, please post your own topic.

  21. daevid
    Member
    Posted 1 year ago #

    Having solved it by following the advice in this thread: http://wordpress.org/support/topic/w3-total-cache-error-files-and-directories-could-not-be-automatically-created-t?replies=16

    People who are having problems with this. I've solved it by making the .htaccess file temporarily writable.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic