Support » Plugin: W3 Total Cache » W3 Total Cache Error: Files and directories could not be automatically created t

  • Since the latest update of W3 Total, I have received the error as per topic title. Full text of error reads:

    FTP credentials don’t allow to write to file /home/xxxxx/public_html/.htaccess
    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.
    Please execute commands manually [button: view required changes]
    or use FTP form to allow W3 Total Cache make it automatically. [button: update via FTP]

    Viewing the required changes, I get:

    Edit file /home/xxxxx/public_html/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    The trouble is that when I looked in .htaccess, the above mentioned strings do not appear to exist. When I pressed the “update via FTP” button, I did not get a form to fill in my FTP details; just a blank line appeared (not a field) and nothing else happened.
    W3 Total was working prior to the update and I had made no changes following the update.
    If I deselect “Remove write permissions from .htaccess and wp-config.php” in Better WP Security, the error message disappears. I do not want to deselect this feature of Better WP Security and W3 Total had no problem with this setting prior to the update.
    I would appreciate if anyone had an insight into the cause of the error message and how I might be able to resolve the situation. As it is I am running W3 Total with the error and I don’t know what impact it is having on performance or security.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 27 total)
  • Another thread has just started (no solutions yet) which seems to focus on the same error type/message as the one I mention here.
    http://wordpress.org/support/topic/new-update-didnt-workw3-total-cache-error-files-and-directories-could-not-b?replies=3

    Plugin Author Frederick Townes

    (@fredericktownes)

    Can anyone having this issue please submit a bug submission form from the support tab of the plugin or reach out to me directly?

    Hi, I’ve got the same issue when Better WP Securiry function “Remove write permissions from .htaccess and wp-config.php” is activated.

    Turning this on will set the unix file permissions to 0444 on these files and turning it off will set the permissions to 0644.

    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.

    Edit file /mysite.com/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    organicjar

    (@organicjar)

    Hi!
    I’m getting the same error.
    ANY SOLUTIONS YET?

    Richard

    (@blandydoes)

    Same error with no solutions yet 🙁

    Taubin

    (@taubin)

    I’m having the same issue. I’ve submitted a bug report through the plugin support page as requested. Hopefully it helps get this resolved.

    Timothy Couckuyt

    (@devplus_timo)

    Any solution on this issue?

    jherrero7

    (@jherrero7)

    I tested the plugin on several websites I manage. Does not work properly on any of them. I tried it in a web bouncy castles but not working properly.

    Timothy Couckuyt

    (@devplus_timo)

    A client of mine just reported this issue being the cause of a conflict with the qtranslate slug plugin. This might help 🙂

    Dries Vints

    (@driesvints)

    People who are having problems with this. I’ve solved it by making the .htaccess file temporarily writable.

    tomdkat

    (@tomdkat)

    Has anyone experienced this issue since upgrading to W3 Total Cache 0.9.3? 0.9.3 is supposed to address this issue, apparently.

    Peace…

    dm5k

    (@dm5k)

    Having the same issue since 0.9.3

    Same thing here, I had posted a bug report to the dev, and he stated it should be fixed with the most recent update, however the most recent update is the one that broke this for me.

    I fixed my issue by deselecting “Remove write permissions from .htaccess and wp-config.php” under the “Tweeks” tab in Better WP Security plugin setting options.

    Hope this helps someone.

    @davidpmurphy that worked for me. Thank you!

    @bit51

    Is there anyway to leave “Remove write permissions from .htaccess and wp-config.php” on and allow W3TC to do it’s thing? Adding the exclusion didn’t allow it to write to wp-config.

    Thank you!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘W3 Total Cache Error: Files and directories could not be automatically created t’ is closed to new replies.