Support » Plugin: iThemes Security (formerly Better WP Security) » W3 Total Cache Error

  • Today I updated to the current WP version, then updated the latest version of my theme. After that, I updated all plugins with new versions, including iThemes Security and W3 Total Cache. W3 shows an error that “files & directories could not be automatically created to complete the installation.” and it says “FTP credentials don’t allow to write to file {my ID’s}/public_html/.htaccess

    Is this a setting that I should change in iThemes to allow my plugins to update?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • MATT M

    (@beardedginger)

    Hi,

    If you want to make changes to those files it’d probably be best before securing the files with the Security settings. Security attempts to disable access to modifying them.

    I hope this helps.

    Thanks,

    Matt
    iThemes.com

    They want .htaccess at 644 but through your advanced settings I have it at 444.
    * Is there an easy way to “let them in” through an exception … but still keep it at 444 for everyone else?
    * If no other way, is it OK for me to just toggle your check-box [on/off] for “Remove file writing permissions” within your SystemTweaks’ Advanced Settings?
    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.