Support » Plugin: W3 Total Cache » W3 Total Cache Clodflare. Load time 3.75 sec. :-(

  • I have been horsing around with this combo for a few days now and I cant seem to find a good setting that will work for me. W3 Total Cache is a little confusing and I’m not sure if my settings on cloudflare are helping or hurting W3 Total Cache.
    Has anybody got a list of settings that works well with cloudflare and W3 Total Cache?
    My home page is very simple with mostly text and hardly any widgets or images yet I can’t get the page to load under 3 seconds. My home page = http://giveawaygator.com/

    I’m also using Lazy loader and DBManager to help with load time and keep the data lean and mean.
    Before I started my Home page took 11 seconds to load so the plugins have helped but I just dont get why I can’t get below 3 seconds. Any help or ideas would be much appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 19 total)
  • first off, it appears that page caching isn’t working. If you’re using disk enhanced, try disk basic. (sometimes disk enhanced doesn’t work)

    The individual files look like they’re each loading quickly, but you’d have much better results if you combined them by enabling minify for css and js as well as inline xml/html, etc…

    The option in browser cache to add a query string to prevent caching – uncheck that for everything.

    I created a video walkthrough to set up w3c not including actually adding each css and js file to minify:

    http://www.youtube.com/watch?feature=player_detailpage&v=YAQFC7PPEGU#t=435s

    though the guide tells you to do manual minify – I’d recommend trying to go with auto, and if that doesn’t work, you’ll need to sort through your html and add each js and css path manually.

    I am having issues with my site http://www.imagewize.com as well. Added Cloudflare and W3 Total Cache. But Cloudflare does not seem to work as of yet.. Page Cache is on and under General Tab I added the Cloudflare details. Cloudflare free was activated via Dreamhost and I checked the account and the domain has been added..

    Rhand:
    It looks like cloudflare is “working” just not very well. Files are being served up from there, but there’s a really long wait time on some of them.
    You should probably login to your cloudflare account and see what’s up. The interface there is pretty self-explanatory.

    Your page caching is working, but you need to disable xcache – it can actually hurt performance if you’re on shared hosting.

    The only things you should have enabled on general tab are page caching, browser caching, maybe minify, and in your case – cloudflare.

    Cloudflare should be tested after W3TC gets dialed in, and you should use a real CDN product like MaxCDN for the best performance benefits.

    If page caching isn’t working, I can take a look and try to troubleshoot (we make W3TC): http://www.w3-edge.com/contact/

    Note that Cloudflare and W3TC can do a lot of the same things, so it’s possible to configure things such that they have a negative impact (if files are being minified twice, for example).

    If you’re able to cache against an opcode, try enabling this for object caching and database caching. I’m happy to help dial in settings as well if you’d like help of course.

    Happy Monday.
    I turned off minify in W3TC but I enabled it in Cloudflare.
    went with disk basic on W3TC
    Turned off database cache on W3TC(I’m self hosted on Godaddy so not sure if I need this or not)

    On cloudflare I set >Individual performance settings< to aggressive.
    On cloudflare >Rocket Loader< is set to off. I use Rafflecopter and had some problems with the widget not showing up when I had Rocket Loader set to automatic.
    cloudflare Auto Minify is on for all three options.

    I’ll purge both W3TC and Cloudflare and later I’ll see what I get. here http://gtmetrix.com/
    looks like this is going to be trial and error. lol

    Again, I’d recommend disabling CloudFlare completely first.

    And I’d have W3TC implementing minify, not CloudFlare, but that’s my preference.

    Object and Database caching should be disabled if you can’t cache against an opcode.

    You’ll definitely want to find new (better) hosting if you’re serious about performance, GoDaddy just isn’t going to get you where you need to be unfortunately.

    Bluehost is a fine provider if you’d like a recommendation for a shared hosting alternative that’s affordable and can facilitate better performance.

    I set cloudflare to CDN only for now while I mess with W3TC. Is that what you mean?
    I set minify on W3TC now and so far I’m down to 2.75 seconds (sometimes 3)
    I started with Godaddy and will stay the time I paid for but the plan has been to move when traffic picks up. I have made a note on my calendar to check out Bluehost when my hosting with Godaddy comes to a end in Jan.

    Oh Unrelated. I also noticed that my social share buttons on my pages was taking some time to show share count so I turned the counter off. I dont need to show how many people shared my content and I can see that info elsewhere.

    No, disabling completely means disabling completely 🙂

    https://www.cloudflare.com/my-websites > [gear dropdown to the right in the current version of the dashboard] > Pause CloudFlare.

    Good luck!

    lol I did see that. Paused and for now I’m running on W3TC only.

    Thanks guys I think I have it.
    Google PageSpeed Insights gave me a 97 and Yslow gave me an A too. last test was 1.10 seconds. I used the most basic settings one at a time in W3TC until I got it the best it could be. I used auto minify with default settings in W3TC. Object and Database caching turned off.
    I turned on cloudflare again first to CDN only and then tested rocket ship to see if it would work for me. I’m still figuring out if Rocket ship is right for me but no problems yet.
    I emailed my subscribers and asked to evaluate the site and they are happy with the results.

    Glad to hear it, thanks for the update.

    @ bheadrick Turned off xcache. Clouflare is working. No idea how to check for issues. Just had a server reboot so there are still issues that is clear. Did turn on W3T Cache before Clouflare so that was done well..

    @rhand Member.
    I did what Willie said to do. I turned off cloudflare by pausing it. your site still works it just bypasses cloudflare. I Turned off all settings on W3TC and then turned them on one at a time starting with Cloudflare, Page cache, then Browser cache and finally Minify. I messed with the settings of each before I turned on the next. Turns out Minify works great in default.
    Finally when I got W3TC to a good place without it messing with my RSS , widgets or images I turned cloudflare back on to CDN only and let it do its thing for a day or so before testing the site.

    W3TC settings are on for Page cache, Browser cache, minify and cloudflare. On Cloudflare the settings are CDN only and then turn on Rocket Loader and let that run for a bit to see if it helps or hurts.
    Basically the page optimization settings are all in W3TC and Cloudflare is only a hub. (unless you add rocket loader)

    Additional plugins
    I also use a lazy loader plugin so my content below the fold does not load until you scroll down to it and that helps.
    Revision Control plugin keeps my saved content less cluttered.
    WP-DBManager plug in backs up the site and optimizes my data.

    Other than this forum..This is the posts that got me started and where I got all the info I needed. In this post, you’ll find everything you need to know, if you have been wanting to speed up WordPress sites that you own.

    Hello – I know this thread is a bit dated but it’s relevant to issue I posted here: http://wordpress.org/support/topic/slow-speed-results-using-w3tc-cloudflare-incorrect-settings?replies=1

    I did my best to distill as much info regarding settings from here but still struggling to find sweet spot.

    Would appreciate input if anyone on here has achieved optimal performance using W3TC & CloudFlare.

    Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘W3 Total Cache Clodflare. Load time 3.75 sec. :-(’ is closed to new replies.