Support » Plugin: W3 Total Cache » W3 Total Cache breaks layout

  • W3 Total Cache is the only plugin that really works with increasing speed across my sites. However, the CSS Minification is breaking column layouts in product rows. You can see on the URL under featured products there is a row of four products in four columns. Column 3 and four do not have any spacing between them. If i turn off CSS minification the correct spacing returns (but with a massive drop in page speed).

    Is this a compatability issue with wp 4.8.1?

    This occurs across all sites where I am using DIVI + Woocommerce + W3 Total cache. When the display is three columns, it is columns 2 and 3 that are joined.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Ben

    (@benbornschein)

    The issue with third party plugins like WooCommerce, DIVI, or Visual Composer is, that they register and/or enqueue scripts not at the time when the scripts should be enqueued. That’s why many plugins, which try to merge JavaScript and CSS, fail in some cases. I think the same happens here. We developed our own caching plugin (free/premium) https://borlabs.io/ which tries to merge every CSS and JavaScript. But the problem is always, that you have to deal with third party developers, who do very unusual things to ensure, that their JavaScript/CSS is loaded. Worst of all is the plugin NEXTGen Gallery. Anyway, since yesterday we added a second method for CSS/JS merging to deal with such plugins, if you like, you can give our plugin a try (it’s free). Just use “method b” and it should work.

    If you want to stay with W3 Total Cache, you can try to rearrange the CSS, maybe this fixes your issue.

    Hi Ben, I downloaded and tried your caching plugin but my page speed is now 44 down from 77. It has fixed the layout issue but i think that is because it isn’t minifying any of the CSS or javascript (according to google anyway).

    W3 total cache is the plugin that works for me just with this layout issue that I think is more to do with how it is working with woocommerce.

    Ben

    (@benbornschein)

    Ahm, I guess you haven’t activated the plugin because with my plugin you always get a score above 70 😉

    After you have enabled the plugin, you have to go to “Borlabs Cache > Dashboard” and select “Default” cache preset. Click save and apply and reload your page in a new private window. The first request is slow because it generates the cache file, but after that, you get your site in milliseconds.

    If you need help with the setup, just contact me 🙂

    • This reply was modified 2 years, 5 months ago by Ben.

    Hi Ben, that’s what I had done but I am not getting anywhere near a score of 70. Pagespeed insights are saying that html is minified but javascript and CSS is not. Page score 44 on page http://www.supermixhire.com

    Ben

    (@benbornschein)

    Can you go to “Borlabs Cache > Support” and create a ticket? I can help you with the setup and check, how I can improve the speed of your site.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘W3 Total Cache breaks layout’ is closed to new replies.