Support » Plugin: W3 Total Cache » W3 Total Cache breaks Elementor Pro page Builder

  • Resolved guillermop

    (@guillermop)


    I’m having an issue with your plugin, basically it messes up with the page CSS, inside Elementor the web looks fine but when the page is published looks without the proper CSS.

    I emailed Elementor’s support and after a few emails and test we identified that W3 Total Cache was causing the issue.

    Now the plugin is deactivated and the web looks fine, I’ll be happy to send you all the information you might need in order to fix this bug.

    Kind regards

    Guillermo

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @guillermop

    I am sorry about the issue you are experiencing and I am happy to assist you with this.

    If minify is enabled on Auto, you should exclude Elementor CSS (and possibly JS) from being minified in Performance>Minify, Advanced sub-box, “Never minify the following CSS files:” and “Never minify the following JS files:”
    The other thing you can do is switch to Manual Minify and add JS and CSS files Manually and in the proper order.
    I hope this helps!

    Hi @vmarko,

    Could I trouble you for some more detail on this issue? Elementor loads a lot of stylesheets, should they all be excluded?

    If I was to switch to Manual Minify, what would be the proper order to minify the CSS and JS files?

    Many thanks,

    Andrew

    I believe the solution to this issue, is to eliminate the rendered post file generated by elementor (External CSS setting) from the minification (w3tc set to auto).

    Add this to functions.php or theme/plugin referenced file.

    `// define the w3tc_minify_css_do_tag_minification callback
    function filter_w3tc_minify_css_do_tag_minification( $do_tag_minification, $style_tag, $file ) {

    if($do_tag_minification && isset($file) && strrpos ( $file , “elementor/css/post” ) >= 1){
    return false;
    }

    return $do_tag_minification;
    };

    // add the filter
    add_filter( ‘w3tc_minify_css_do_tag_minification’, ‘filter_w3tc_minify_css_do_tag_minification’, 10, 3 );

    • This reply was modified 1 year, 8 months ago by Nate1.

    EDIT: The issue still appears to occur with the above, but appears to be more stable.
    A combination of the above, page_cache, minify and database cache appears to be working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘W3 Total Cache breaks Elementor Pro page Builder’ is closed to new replies.