Support » Fixing WordPress » [Plugin: W3 Total Cache] W3TC and WP-Polls

  • Hi:

    I’ve been trying to set up W3TC to work with WP-Polls to no avail. At my site I display a poll in a widget, but with cache enabled no one can vote (it shows poll results, but not poll options), except by entering in the poll archive. I tried using the “Never cache the following pages:” option by including “wp-polls” in the list, but either I’m not using it right or there’s something I don’t know. Anyway, cache for home page is disabled for now. I’m Using W3TC and WP-Polls 2.50.

    ¿Any ideas? thanks in advance.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Can you submit a bug submission form from the support tab of the plugin so I’ll be able to see your settings.

    Done. 😀

    I’ve just checked and it seems that W3TC doesn’t play well with WP-Polls; even with no home page caching WP-Polls breaks. Fully disabling W3TC works, but that’s obviously not what I want. Hope that helps.

    I wasn’t able to duplicate it in testing. It’s possible there was a case I did not test. Please advise.

    It doesn’t work in cached pages (with WP-Polls, that is); in non-cached pages (my blog home page for example), it shows the poll correctly. But suppose you haven’t voted, when you visit a cached page, you will see poll results, but not poll options.

    It’s a shame, because the plugin really helped my blog; it helped it so much that I’m considering getting rid of the polls plugin. Anyway, if someone comes up with a solution, please let me know.

    Thanks for your help fredericktownes.

    I still don’t understand the use case; I didn’t find an issue. I just tested a site that has the AJAX implementation there and it worked fine. If you would provide the URL where I can see it I will look at it or reply to my last email.

    I just ran into the same issue. In my case I am using MaxCDN and it was serving the plugin files from the CDN.

    I had to add wp-content/plugins/wp-polls/* to the rejected files list (in the CDN section) to fix it.

    You have not minified files that can/should be minified and you have added files to custom files list with insufficient specificity.

    I have the same issue. WP-Polls does not work correctly when W3 Total Cache is enabled.

    What happens is that the poll is displayed, and as soon as one user votes, then that vote is cached for all subsequent users. The problem seems to resolve when I’m not using minify

    I am also noticing that in IE, even with minify turned off if I click on “View Results” the AJAX ‘loading’ icon comes up but the results page is never loaded. The problem is resolved by turning off W3 Total Cache entirely.

    I didn’t have this problem using other caching programs, but I’d really like to switch to W3TC, this is the ONE incompatibility I have across all my blogs. Polls are important.

    I have narrowed down the problem behavior further.

    WP-Polls doesn’t seem to work correctly (continual spinning loading icon” in IE when I use either of the following options:

    “Rewrite URL Structure”
    “Minify HTML”

    By leaving both of these turned off it seems to work in IE.

    Correction. WP-Polls doesn’t seem to consistently work even with those two turned off.

    WP-Polls uses an AJAX implementation on your site right?

    Same issue here.
    WP-Polls is in fact using ajax.

    The site is if you wish to see the behavior.

    Anyone who has submitted a bug request hasn’t heard from me, please re-submit.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: W3 Total Cache] W3TC and WP-Polls’ is closed to new replies.