WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3 Total Cache and domain mapping issue (4 posts)

  1. Diwoto
    Member
    Posted 7 months ago #

    Hi, we have a WordPress mulltisite setup with domain mapping.
    We are trying to use the plugin but it seems like the plugin is not able to prime/purge the cache for domains that are being mapped. The plugin will create the initial page cache properly but then the cache doesn't seem to update.

    We found that the plugin works correctly for sites without a mapped domain (multisite.com/muclient) but when it is using a mapped domain, it will not purge the cache found in the muclient.com folder (where it created the initial cache). We thought that maybe it was a permission issue but the cache folders where it is not linked to a mapped domain seem to work just fine.

    Where do you think the issue is? Is it an issue in the root .htaccess?

    Thank you for reading this.

    https://wordpress.org/plugins/w3-total-cache/

  2. Action Turtle
    Member
    Posted 7 months ago #

    This is good to know... What a bummer that W3TC does not work for mapped multi sites... Hope support will come soon...

    Are you on apache? I am on NGINX... I hope they support both...

  3. Diwoto
    Member
    Posted 6 months ago #

    Hey Action Turtle,

    Thanks for responding. We figured out that unchecking "Redirect administration pages to site's original domain (remote login disabled if this redirect is disabled)" in the domain mapping settings actually allows w3 total cache to work. The side effect of this is that each site must be logged into separately.

    This option isn't perfect but it at least gets domain mapping and w3 total cache to work.

    We are on apache, haven't tried it on NGINX.

  4. fleckebk
    Member
    Posted 2 weeks ago #

    Diwoto, thank you for writing this post! I'm willing to sacrifice logging into each mapped site separately for the added benefit of the cache plugin working properly. Changed the setting, and it worked immediately.

Reply

You must log in to post.

About this Plugin

About this Topic