Support » Plugin: W3 Total Cache » W3 Total Cache Causing Blank Admin Panel

  • Resolved kayvic01


    I have just upgraded W3 Total Cache to, after which the whole admin area has completely disappeared.

    The public side of the website is still rendering for now.

    When i do a view source of the admin area (wp-admin) its completely blank.

    Can you please assist in resolving this issue. Thanks.


Viewing 10 replies - 1 through 10 (of 10 total)
  • I also would be grateful for some help here. Just installed this plug in and now can no longer log in the admin page. As a wp newbie need help in words of one syllable!

    It could be an out of memory-Problem (on the dashboard which tries to open first).
    Try to login into
    if you are using a subdirectory (/blog/).
    Then disable the dashboard functions of W3TC (at the end of settings / general).
    (They perhaps need too much memory).
    (it is a german site, but there is a translate button in the right upper corner)

    gets you directly to the plugin page.

    Good Luck

    No niether worked. Can’t access either the plug ins page or w3tc

    I have totaly removed the plugin via FTP and now the admin screen works.
    Won’t now touch W3tc till the problem is fixed.

    I meet the same problem. Although I removed the plugin via FTP, the admin area still completely blank. And the w3tc folder can not be removed. How can I completely remove them?

    Hi All,

    I don’t know if the plugin developer has release a fix to W3 Total Cache, but i have been able to resolve the issue.

    Remember that the issue was introduced in W3 Total Cache Hence the solution is to revert back to the previous version.

    Steps to follow:
    1) Logon to websites ftp account
    2) Change your current directory to <Web Site Root>/wp-content/plugins
    3) Delete the following folder: w3-total-cache
    4) Visit:
    5) Download: W3 Total Cache – To you local computer
    6) From the above download, copy folder: w3-total-cache to <Web Site Root>/wp-content/plugins of your website via ftp
    7) You should now be able to logon to WordPress.



    There is an issue in the rewrite test that this plugin does to see if that is configured. I do use nginx as webserver and I suspect that it has got something to do with that but for me what worked was comment out the rewrite test the plugin does when you click on ‘Performance’ section.

    searh/change the if statement in this file:

    if (!$this->test_rewrite_pgcache()) {

    should be this to skip the pagecache rewrite check:

    if (1==0) {

    If you mod that the page will load directly.

    I had the blank page problem in the spring with my #1 blog. It was resolved by chmodding the folder permissions manually. Cause of the problem wasn’t verified. Today this happened with other two blogs and the cause is verified to be W3TC

    1. Installed it to a newly-installed blog. All pages give now the error message “403 Forbidden
    You don’t have permission to access / on this server.” The whole site is inaccessible after installing W3TC

    2. On another blog that has had W3TC for a while resulting in 90 / 100 in Google PageSpeed, I installed BulletProof Security .46.3. After letting it create secure .htaccess files, W3TC warned it needs to be redeployed. After clicking “Redeploy”, all pages under wp-admin give “403 Forbidden
    You don’t have permission to access /wp-admin/ on this server.” The admin pages are inaccessible after redeploying W3TC

    All three blogs are running on Apache 2.2. Both blogs that got problems today were WP 3.1.3.

    Timlock, kayvic01 and noanylove: Is the the exact same problem you had?

    W3TC Developer(s):
    Is this a known issue to you? Is there some additional information I could provide to help in solving the issue?

    Everyone: You all know that caching is important, but admin panel downtime and especially whole blog downtime is absolutely to be avoided. Those downtimes have happened three times for me with W3TC. Can you suggest other cache plugins that don’t have the same risks as W3TC? What about Hyper Cache + DB Cache Reloaded Fix? is the earliest comment I’ve seen, stating that the has problem existed at least since Jan 24.

    Plugin Author Frederick Townes


    All issues reported to me about this issue are fixed in the latest release. There are LOTS of causes of this issue and it’s unreasonable to assume that it’s an errant bug that has persisted in the plugin.

    Very good news about the fix. Thank you for the heads up and for your continued efforts for the WordPress community.

    For BulletProof Security a similar problem was solved by making sure that .htaccess and directory permissions are never set to 600 but to 644 instead. This is crucial on hosts with suphp installed. The discussion can be read at

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘W3 Total Cache Causing Blank Admin Panel’ is closed to new replies.