WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » W3 screws up NextGen gallery

W3 screws up NextGen gallery

  • Hi,

    My W3 is screwing up my NextGen gallery. I don’t use the slideshow version, I am just posting the photos as thumbnails and then you click and it enlarges. The photos are self-hosted and not on a CDN.

    When I disable the plugin it works fine, if I enable it, the thumbnails all appear under each other and when you click it goes straight to the image rather than enlarging nicely in a lightbox-style box.

    Any idea how to fix this? Thanks.

    http://wordpress.org/plugins/w3-total-cache/

Viewing 8 replies - 1 through 8 (of 8 total)
  • @colinwo

    W3 Total Cache can screw up nggallery after updating W3. Slows down gallery saves or editing a gallery.

    When I update W3 I immediately repair and optimize the database so it won’t affect nggallery.

    I know there was an update the other day.

    Makes my site a nightmare on the back end. Usually lasts a week if you don’t optimize or repair the database.

    Good luck.

    I think the problem has to do with the Javascript or something because everything loads, just not the way it is supposed to show though.

    I did the update but it didn’t fix it. I had to disable W3 for now until someone can give me a solution unfortunately.

    W3 caches your site.

    When you update W3 it seems like it has to start over caching.

    So in the interim nggallery suffers.

    If you repair and optimize your database you’ll be ok. I do it all the time.

    If you don’t know how to repair or optimize your database then you shouldn’t be playing with the database.

    Sorry if you don’t find this helpful in any way.

    Good luck.

    Colintwo, I had the same issue.

    I wrote Illustrated tutorial on how to fix many plug ins that W3 TC breaks exactly to help you, it fixed my issue with NextGen gallery for me. It’s just a couple of posts down yours in this forum.

    Ugh those instructions broke my lightbox.

    Ugh those instructions broke my lightbox.

    Those instructions clearly mention lightboxes as one of the top priority javascript to exclude from minification.

    If you included it and W3 TC breaks it, you have to:

    1) Check the instructions again
    2) Simply remove the lightbox javascript file from the list of included files and clear the W3 TC (minify) cache.

    Thank you, I’m going to try this one out!

    @dfumagali

    I did exclude.

    My way works fine. Thanx.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘W3 screws up NextGen gallery’ is closed to new replies.
Skip to toolbar