Support » Plugin: W3 Total Cache » W3 Minify option broke mobile header

  • Resolved zlatanov

    (@zlatanov)


    Hey team,

    I updated my WordPress theme yesterday, purged all cache and then individually purged all available options. Everything worked perfectly on desktop but I noticed that on the mobile version my header is modified. On mobile now I have two search bars instead of one, and none of them works. So I started to disable all functions to see which one causes this particular problem and found that the Minify option is to blame. When I disable it, the problem disappears. Naturally, I would like to have this option and don’t want to disable it. Any ideas about what could help?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @zlatanov

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Can you please share which theme you are using and your website URL?
    Can you also please enable minify in Performance>General settings and save all settings. then go to Performance>Minify and disable the settings(HTML minify, JS minify, CSS minify) one by one followed by saving all settings and purging the cache. See which minify setting might be causing the issue.
    Thank you!

    Hi Marko,

    thanks for your answer. I did everything that you asked for 4 different devices and the problem was caused by JS minifying option. When I disabled it, the second search bar disappeared. However, there I have minified many js scripts that slow down the page and I don’t want to give up this option. I contacted the theme developer and he says the issue is caused by w3 plugin. The WP theme is Rehub. Any ideas of how I could proceed further?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @zlatanov

    Just to confirm, this issue started to occur only when you updated your theme is that correct? If that’s the case, and W3 Total Cache worked normally with the previous version then it’s caused by the update.
    Is minify enabled on Auto or Manual? Also what Embed type: you are using? There is a possibility that the specific JS needs to be excluded from minifying in the “Never minify the following JS files:”
    Adding the path E.G. /wp-content/themes/yourtheme/js/filecausingtheissue.js to that filed will exclude that file from being minified.
    Thank you.

    Mark this as solved! Thank you, Marko!

    I use manual minify mode and there I have put mywebsite/wp-content/themes/mytheme/js/custom.js?ver=9.7.4 for minifying which caused obviously the problem. I clarify this in order for other people to read and solve their issues in the future. be careful about what you are minifying! So when you update your template make sure that you don’t minify your old theme version.

    • This reply was modified 2 months, 2 weeks ago by zlatanov.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @zlatanov

    Thank you for the information. I am glad that your issue is resolved.
    We would really appreciate it if you could take a minute and post a review here. This will help us to continue offering a top-notch product to users.
    Thanks!

    Done! thank you

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.