Support » Plugin: W3 Total Cache » W3 conflicts with Divi theme builder

  • Hello

    I’ve found that W3 conflicts with Divi theme builder.
    When W3 is activated, many builder functions do not show on builder preview. Deactivating W3 solve the matter.
    Divi support is aware of this and they point to you.
    Will appreciate if you’ll fix this
    Thanks

Viewing 14 replies - 16 through 29 (of 29 total)
  • i have just sent the log @ https://www.w3-edge.com/contact/

    Hey there,
    I have the same issue.
    I’ve just found out how to solve it (I hope)
    You have to disable the minify for logged in users in minify->General.
    Seems to work fine for me now with last version of DIVI.

    • This reply was modified 1 year, 2 months ago by logarank.

    thank you @logarank
    I gave up W3 months ago, too much work and conflicts )-:

    grumo64

    (@grumo64)

    HI there,
    for me if I enable gzip in browser cache media section then I could not load existing page anymore.
    Please help.

    https://physioaadhar.com/
    hello sir
    I am using w3 total cache but when I activate plugin divi visual builder just keep lording does not lunch, but when I disable the plugin divi start working fine can you suggest any solution how to fix it.

    Hello, same problem. when w3 total caché it’s activated Divi builder doesn’t works.

    The solution that worked great on my website (lianochko.com.ua) is choosing the main Divi theme in JS file management and CSS File management setting, instead of child Divi theme (Divi-child in my case) in W3 minify tab.

    Step by step:

    1) General Settings page –> Minify mode –> Manual
    2) Minify page –> JS –> JS file management: –> Divi
    3) CSS –> CSS file management: –> Divi

    • This reply was modified 9 months, 3 weeks ago by rossanino.

    I did some extra digging on this. Lazy loading also screws up the builder loading. If you enable it, then go into the settings Performance> User Experience and then disable Process HTML Image Tags and leave Process Background Images active, the loader still works. Additionally, the suggestion from @logarank worked for me.

    Currently waiting on Divi to reply to me on the suggestion from @rossanino because, from what I can see, enabling the minify options under the themes section slows down the site.

    I dont know whos end this needs to be fixed on, but it would be great if it could get fixed! Im telling Divi the same thing.

    Hi There

    Is there any solutions to this Issue?
    I’ve found the same problem.

    I found a conflict between W3 Total Cache and the Divi Theme Builder.
    If in W3TC Minify On, Divi Theme builder and Integrations via Divi Theme Options don’t work.
    Do you have any advice on this?

    I have this issue too. The Divi Icon spins and spins and never resolves. When I deactivate W3 Total Chache everything works

    For others who may have searched for this issue.

    I found the Minify settings to be the problem.

    I have found that if Minify is enabled in the General section, but the “Disable minify for logged in users” box under the Minify section is checked, I am able to then edit Divi Builder pages in both “wireframe” and “visual builder” mode, at least right now.

    I don’t remember where I got this solution when I had it previously, or why it seemed to pop up again, but at least on the 2 sites I tested this on, it seems to work.

    Ugh, apologies to logarank above, as I see that must have been where I found the solution originally. That’s what I get for scanning through this page, rather than reading carefully.

    tschweitzer

    (@tschweitzer)

    I found (Divi builder was spinning endlessly) the solution from two users above solve the issue for me

    ——————–PArt 1 solution——————
    rossanino (@rossanino)
    5 months, 2 weeks ago
    The solution that worked great on my website (lianochko.com.ua) is choosing the main Divi theme in JS file management and CSS File management setting, instead of child Divi theme (Divi-child in my case) in W3 minify tab.

    Step by step:

    1) General Settings page –> Minify mode –> Manual
    2) Minify page –> JS –> JS file management: –> Divi
    3) CSS –> CSS file management: –> Divi

    ——————Part2 solution —————–
    blreed89 (@blreed89)
    4 months, 2 weeks ago
    I did some extra digging on this. Lazy loading also screws up the builder loading. If you enable it, then go into the settings Performance> User Experience and then disable Process HTML Image Tags and leave Process Background Images active, the loader still works. Additionally, the suggestion from @logarank worked for me.

    Currently waiting on Divi to reply to me on the suggestion from @rossanino because, from what I can see, enabling the minify options under the themes section slows down the site.

    I dont know whos end this needs to be fixed on, but it would be great if it could get fixed! Im telling Divi the same thing.

    I’ve noticed that the Minify for css conflicts when you have CSS in the Divi Theme Options “Custom CSS” section.

    However, if you use only a child theme for your CSS, there doesn’t appear to be css rendering conflicts.

Viewing 14 replies - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.