W3 Total Cache
W3 + Cloudfront not serving my files as cdn (7 posts)

  1. MichaelXCheng
    Posted 3 years ago #

    so i've been attempting to use Cloudfront for my new personal wordpress site.
    i dont have my files on S3. im using direct origin to my website hosted on hostgator.
    i set up the cloudfront distribution with http only point to my website url with custom ttl of 0.
    i pointed my cname called cdn.michaelxcheng.com to the domain provided cloudfront.
    i waited for the distribution to be deployed.

    then i went over to my w3 plugin in wordpress
    everything is default cept i turned on Set expires header and Set entity tag (eTag)
    i enabled on cdn, chose origin pull - amazon cloudfront
    went over to cdn tab, entered my access id and etc. Replace site's hostname with my own cname.
    tested the distribution and it passed.

    i went over to webpagetest and none of my files are being served by the cloudfront
    i went over to cdn.michaelxcheng.com and noticed none of the files are on the cdn either
    did i miss something or do something wrong?
    thank you

    PS:i have videos hosted on s3 with cloudfront cdn, no cname, and they stream perfectly thur cloudfront.


  2. MichaelXCheng
    Posted 3 years ago #

    in case another plugin is causing this problem
    here are a list of plugins i use that are related
    Better WordPress Minify
    Disable Comments
    SEO Ultimate
    Use Google Libraries
    Video.js - HTML5 Video Player for WordPress
    W3 Total Cache

  3. MichaelXCheng
    Posted 3 years ago #

    please note i've attempted deleting reinstalling w3, disable-delete-recreate my cloudfront distribution, changing cname, trying without cname.

  4. MichaelXCheng
    Posted 3 years ago #

    i've also used cloudflare and maxcdn on this wordpress blog via w3 without problem. but i switched to cloudfront as its more cost efficient.

  5. bheadrick
    Posted 3 years ago #

    that's odd - some of your content is getting picked up by cloudfront, but not all of it. You're using origin pull?
    according to webpagetest, it looks like it's only picking up js and css, so maybe add uploads to the folders that get served by cdn as well as /wp-content/plugins

  6. MichaelXCheng
    Posted 3 years ago #

    problem solved. mod please delete my post. thanks

  7. titush
    Posted 3 years ago #

    what was the solution?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.