Support » Plugins and Hacks » W3 and WooCommerce / Shopping Carts

W3 and WooCommerce / Shopping Carts

Viewing 15 replies - 16 through 30 (of 56 total)
  • Thanks again for your reply. Figured out my problem yet, was a page caching issue. Hope I can help you with this:

    My settings are the same as your settings, except from

    [X] Disable cookies for static files (I got this turned on)

    Got to go in a minute, but will reply later if you need something that could help you out.

    nop, this does not solve it. : (


    Set expires header

    is checked adding to car works but deleting does not.

    if set cache control is set it works 🙂

    Set cache control header

    So basically i’ve got :

    [ x ] Set Last-Modified header
    [    ] Set expires header
    [ x ] Set cache control header
    [ x ] Set entity tag (eTag)
    [    ] Set W3 Total Cache header
    [ x ] Enable HTTP (gzip) compression
    [    ] Prevent caching of objects after settings change
    [ x ] Disable cookies for static files
    [    ] Do not process 404 errors for static objects with WordPress

    and it seems to work.

    unfortunatly I need the “Set expires header” parameter

    Damn gabrielstuff – you’re right! Just been playing around with my store and found that the add to cart functionality is not working for non-logged in users. I’ve (stupidly) only been testing whilst being logged in, can you bear with me while I just go into the corner and give myself a good kicking….. :'(

    No wonder things seemed a little quiet by way or orders of late. Mainly only repeat business, which now makes sense since only logged in users (existing customers) can add any products to their cart! Damn, damn, damn.

    Anyway, I’ve added:


    to my Database Cache > Advanced > Ignored query stems option box which seems to have resolved the add to cart issue. Thanks for finding that fix.

    My remove from cart seems broken (again as you described) if you click the X next to the product in the cart, but works if you reduce the quantity to 0 then update the cart.

    I’ll do some further testing and report back. I thought it was very strange it seemed to be working for me and not others, since this was almost certainly not through any clever setup on my part!

    James :'(

    Turning off ‘Browser Cache > General > Set expires header’ seems to have solved the delete from cart ‘x’ button not working issue for me.



    as mentioned in the other thread didn’t seem to make any difference. Is the format correct in these terms? From a quick read of the W3TC FAQs here it looks like it should maybe be:




    but I can’t quite make out which. Anyway, I’ve tried all three variations and it didn’t seem to help.

    So for me, turning off the expires header and adding the wc_session as described above seems to have restored cart functionality for non-logged in user, although I’m still testing this.

    Well — finally — adding _wc_session_ to my to my Database Cache > Advanced > Ignored query stems option box fixed the issue with non-logged in users being able to add product to cart. I want to thank all of the above posters for helping me resolve this issue.
    I spent many many hours trying to figure out what in the world was making the cart do this. Now both W3TC and woo shopping cart work great together. YAY!! 🙂

    Hey kwd, James and others,

    I got everything on woocommerce 2.0 working perfect for logged in and logged out users. The only things I did:

    Exclude cart and checkout page from page cache:

    (no regular expressions and/or slashes needed, just the page names)

    Ignore query stems:

    Hope this works for you too!

    emielm; I’ve been mucking about with w3tc/cdn/my server setttings/etc. trying to get them to play nicely together with woo (but really not sure WHERE my slow-site issues have been coming from.

    would you mind sharing your configuration settings, or where you went to find a tutorial that worked for woo and w3tc?

    you can post here, or email me at (this username) at gmail…I’d love to get this all humming along nicely, but as of now I only have browser cache and CDN working; I feel like I’m missing out on a lot of speed capabilities with w3tc.


    @ onlyshawn
    The only thing I did was follow instructions from James post above and it worked like a charm.


    to my Database Cache > Advanced > Ignored query stems option box which seems to have resolved the add to cart issue.

    Take wc_sessions_
    and add it to your query stems. Follow the >’s above to find out where to do this. Hope it works for you. Do this inside your WordPress W3TC settings, not the server.

    All the above solution work fine. Except the :

    [ ] Set expires header

    if set to true, deleting stuff in the cart, won’t work.

    Hi Gabriel stuff,

    You mean to unchecked the “set expires head” to solve it right?


    yes, you have to remove set expires header if you want the deleting feature to work.

    Hi Gabrielstuff,

    Thanks you update here.


    it is strange…

    I have checked
    Set expires header
    and can remove items in the basket.

    But if I put
    in Database Cache > Advanced > Ignored query stems
    it still does not work adding a new item to the basket.

    It is the other way round as mentioned above….

    any ideas?


    timit; UNCHECK ‘set expires header’, I believe, is the issue.

Viewing 15 replies - 16 through 30 (of 56 total)
  • The topic ‘W3 and WooCommerce / Shopping Carts’ is closed to new replies.