Support » Plugin: Very Simple Event List » VSEL injects itself into event page

  • Resolved flomei

    (@flomei)


    Hi!
    I am currently debugging a site where VSEL seems to inject itself into the page again.

    I have narrowed the problem down to VSEL by:
    * Trying different themes, error persists across them
    * Deactivating all plugins except VSEL, error persists

    The user has inserted a mail address and added a “mailto:”-link to the address in the text body of an event entry. This looks perfectly fine in the HTML view in the editor, no additional markup was added.

    Once the page is rendered in the frontend, VSEL(?!?) adds the following code right before the link element:

    <iframe title="REDACTED" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://www.REDACTED.com/embed/#?secret=PUFWJqEH0o" data-secret="PUFWJqEH0o" marginwidth="0" marginheight="0" scrolling="no" width="600" height="338" frameborder="0"></iframe>

    This iframe contains the frontpage of this wordpress instance once again. While most browsers ignore this, Safari seems to stumble upon this and shows two headers for example. Anyway, that iframe should not be there.

    Can this be caused by VSEL? And how to fix it, if it is caused by VSEL?

    Thanks and best regards
    Florian

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi Florian,

    So this happens when client adds a regular mailto link in the (single) event content? This sounds very strange, cannot believe this is caused by my plugin. And the redacted dot com website in this iframe code, is this the website of your client?

    Guido

    Hi Guido,
    that is totally strange, I know.

    I have also found out that a simple, written URL gets converted to a clickable hyperlink with the page title as the link text.

    To be honest I’m not sure if VSEL is even capable of doing things like this, when parsing the event content.

    Maybe it’s some strange bug in the Gutenberg Editor? It seems there was something like this before: https://github.com/WordPress/gutenberg/issues/15102

    Any ideas if this could result from VSEL at all? If not, I will go and have a closer look at Gutenberg. Maybe that’s the culprit.

    Best regards
    Florian

    Plugin Author Guido

    (@guido07111975)

    Hi Florian,

    As the title of my plugin already suggests, it’s a very simple and leightweight plugin that uses many native WP filters and functions. Almost none advanced code.

    You can always insert the same content in a post/page by using the Classic Editor and see what happens.

    Just curious, are you able to give me the full content which causes this strange behaviour? So I can try to duplicate this at my test instal..

    Guido

    Hi Guido,
    just wanted to let you know that VSEL was not the cause of the problem.

    It turned out that WordPress tried to build a preview of the homepage, which was linked in the post, and failed to integrate that into the post itself.

    This embed-behaviour could be deactivated through a checkbox up to some time ago but WP Core broke this and now an oEmbed preview is generated always.

    I found a plugin that deactivates this behaviour, installed it and now the additional markup is gone: https://gist.github.com/ocean90/3796628

    Sorry for bringing you into this. 😀

    Best regards
    Florian

    Plugin Author Guido

    (@guido07111975)

    Great you’ve solved it! Thanks for informing me.

    Guido

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.