Support » Plugin: Garden Gnome Package » VR not loading with another VR in page

  • Resolved eltarny

    (@eltarny)


    Hello,

    We were using the plugin successfully for some months now.

    However, the photographer sent me some new ggpkg files that do not load if they are on the same page as the old ggpkg files.
    They get stuck on loading 0% and show a black screen.

    The browser console shows hundreds of the following error

    Uncaught TypeError: this.Xj.em is not a function
    at c.wj (pano2vr_player.js:416)
    at c.zh (pano2vr_player.js:414)
    at pano2vr_player.js:413

    The photographer claims that he did not change anything while creating the new ggpkg files.

    Can you please help on what we can do during the creation of the ggpkg files to avoid this problem?

    Thank you,
    Elias

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Chief Gnome

    (@ggnomes)

    This can happen if you mix two player versions on a single page.

    To avoid this, you can select a fixed version for all packages in Settings – Garden Gnome Package – Pano2VR – Player Version, and select the latest version in the list.

    Thread Starter eltarny

    (@eltarny)

    Thank you!

    This resolved the issue.

    Hi Eltarny, Wish to know if you update anything from the backend? When I switched Pano2VR player version. My ggpgk still showing loading 0%. wondering how you managed to fixed yours. Cheers.

    Thread Starter eltarny

    (@eltarny)

    Hi antzhayashi,

    The problem is that you may have panoramas from different versions of Pano2VR and they try to load different versions of the Pano2VR player in the page.

    I managed to resolve the issue by copying all the Pano2VR player .js files from only one version in the folders of all the panoramas.

    After you upload a .ggpkg file, a folder structure is created in wp-content.
    You have to choose one of the folders and get the .js files, and take a note of that panorama version.
    Then you have to copy these .js files in the correct folder of every panorama in wp-content.

    There are 4 .js files:
    pano2vr_player.js
    skin.js
    /webxr/three.min.js
    /webxr/webxr-polyfill.min.js

    I also had to edit the pano.xml and the .json file in every panorama to put the correct version, which is: whichever .js files I chose to use. i.e. in my case 6.1.11

    Best,
    Elias

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘VR not loading with another VR in page’ is closed to new replies.