Support » Plugin: Rating System » Votes do not appear to be reliably working (at least not immediately) for nginx?

  • I changed my server to use nginx. However, now the votes do not save.

    I click a vote and I see that the number increases. However, I reload the page and the vote is missing.

    Help!! I loved this but if it doesn’t work anymore that really sucks :'(

    • This topic was modified 3 years, 9 months ago by avw4cc1.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter avw4cc1

    (@avw4cc1)

    I have been trying different browsers and reloading clearing cache everything.

    I found that sometimes it is working and sometimes it is not? I am not sure what is happening here.

    For example, I click some votes and reloaded and nothing worked (0 votes still). I clicked some votes again reload still nothing, I tried two other votes, reloaded, they worked that time. Tried more on some other comments didn’t work again.

    I tried in chrome and upvoted, reloaded and still shows 0, but then opened firefox and it showed 1. Still shows zero in chrome. I tried to upvote it (for 2, I have anonymous on), reload it says 1 again. Reload in chrome it says 0 still, in firefox still shows 1.

    I can’t reliably vote and know if it worked or not. I know nginx works differently than apache but I am not sure what is causing the strange behavior?

    • This reply was modified 3 years, 9 months ago by avw4cc1.
    • This reply was modified 3 years, 9 months ago by avw4cc1.
    Thread Starter avw4cc1

    (@avw4cc1)

    It’s been a few minutes and I went back and tried voting again on the most recent comments which I tried before and it said 0 when reloaded. Except now it said 2 and 2 saved on reload (I think I had first voted in firefox and then chrome, so it would allow 2 under normal operations).

    I just opened firefox again and that still says 1 on both of those comments (better than the 0 it was previously showing).

    Do you think it’s all working but is delaying delivery? I reloaded again and looked at all the comment votes I tried before (I can’t remember all that I tried already exactly because I have lots of different votes from users), and while I can’t be certain I think they are showing? But unsure.

    Some advice could be useful. I am using the latest cpanel, centos, and apache+nginx

    • This reply was modified 3 years, 9 months ago by avw4cc1.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Votes do not appear to be reliably working (at least not immediately) for nginx?’ is closed to new replies.