Support » Plugin: Popup anything on click » void(0 – issue

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Rafik

    (@rafikwp)

    Hello,

    Can you please create new fresh page and add just popup and share URL I will check and let you khow.

    Thanks

    Hello Rafik,

    Many thanks for your reaction.

    I’ve tested it and it only does this on productpages, for some reason. I use the popup on this a productpage: https://www.onlinevleesbestellen.nl/webshop/kalfsvlees/familie-vleespakket-bestellen/

    You can see what happens when you click on the link. Can you check for me?

    Love to hear from you, thanks!

    Hi Rafik,

    I checked and the popup only shows the void(0 link when it’s placed in the top description of the productpage. Do you know how to fix that?

    Many thanks in advance.

    Best regards.

    Plugin Support Rafik

    (@rafikwp)

    Hello,

    Are you talking about these https://prnt.sc/q61vto popup right?
    Both are working fine here see https://prnt.sc/q61xsq

    Thanks

    Hello Rafik,

    No, I’m not talking about those links.

    I had the popup on one of my products for a day, but I had to delete because it was malfunctioning whilst the product was live, and you didn’t response.

    The popup was on the top description of my products (above the USP’s) and above the Add to Shoppingcart-button.

    The popup only malfunctions when it’s placed in the top description of my productpages. It doens’t just popup, it also creates a redirect to the URL + ‘void(0’.

    Do you have any clue how to fix that? Because I really need the popup on my top description position.

    Many thanks for your effort, I apreciate it.

    Beste regards.

    Plugin Support Rafik

    (@rafikwp)

    Hello,

    We are still not able to see the popup.
    Please add it we can not give a solution without a look at it.
    Can you please just add it and share a screenshot where is your popup and also page URL, that it.
    and I guess this is not our plugin issue its looks like any plugin or theme filter or hook causing the issue so meanwhile, you can check it by deactivating one by one plugin and finaly you can temporary swap to the any WP default theme and then check.

    still facing issues find our site join our live chat our technical team will assist you.

    Thanks

    Hello Rafik,

    Thanks for your quick reply – the support is great, I will recommend.

    I’ve added the popup to this product: https://www.onlinevleesbestellen.nl/webshop/rundvlees/rundertong-kopen/

    The popup is called ‘zie inhoud’ (I don’t know how to add a screenshot).

    After work I will try to deactive other plugins and i’ll see what that does.

    Thanks in advance.

    Best regards.

    Plugin Support Rafik

    (@rafikwp)

    Hello,

    It looks like any plugin or theme filter removing “javascript:” from the “javascript:void(0)” so link become only “void(0)” see https://prnt.sc/q6y43s
    It should be “javascript:void(0)”
    And may be this will happen when you add the shortcode in the content so it means causing filter applied on the content only.

    Thanks

    Hello Rafik,

    I’ve deactivated every plugin (also the cache and optimization plugins), yet it didn’t work.

    Does the popup normally work on the place where i’ve placed the popup?

    I will ask my themebuilder of he know’s why it doens’t work.

    Do you got any more ideas?

    I will leave a comment / recommendation on your service – the support is great.

    Plugin Support Rafik

    (@rafikwp)

    Hello,

    Finding an issue without checking all plugin and theme is very hard.
    So I can provide you a temporary solution.
    Please change the plugin code.
    Go to popup-anything-on-click/includes/shortcode/popupaoc-popup-shortcode.php
    find the code line no 79 to 84 https://prnt.sc/q882pq
    just replace the code “javascript:void(0);” to “#” this way https://prnt.sc/q883t9

    Note:-In the future if plugin will update your code will lose.

    Thanks

    Hello Rafik,

    Again thanks for your reply.

    I did what you told me to do, and it fixed that. Is this a temporarely solution, or does it effect the plugin? Why wouldn’t you use the ‘#’ instead of javascript?

    I’ve wrote a review for you.

    Thank you very much for your help.

    Plugin Support Rafik

    (@rafikwp)

    Hello,

    Thanks for your suggestion
    We are using the “javascript:void” because don’t want to append “#” in the URL when click.

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.