Support » Plugin: NextScripts: Social Networks Auto-Poster » Vk authorization error

  • Resolved Mikhail

    (@minus20)


    Hello, there is a problem with Vk.com authorization. Maybe their API has been changed. I’ve got following message:

    {"error":"invalid_request","error_description":"invalid scope"}

    Here is a full request:

    https://oauth.vk.com/authorize?client_id=7306107&scope=offline,wall,photos,pages&redirect_uri=https://oauth.vk.com/blank.html&display=page&v=5.42&response_type=token

    I looked into documentation and found that scope “offline” not available for their open API anymore. And when i tried to get token without this scope i’ve got “wrong IP” error. Seems like they associate token to user’s IP. They have another approach which not require IP, it uses code instead of token.

    Is there any solutions to this problem right now? If not, can I help you somehow?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author NextScripts

    (@nextscripts)

    Your app is offline.

    Please replace the word “offline” in the request line with “online”.

    Mikhail

    (@minus20)

    According to VK documentation: “offline – Access to API at any time”, there is no “online” option. And in russian it’s also said “Not applicable in the Open API.”. Anyway I’m done with it. Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.