Support » Fixing WordPress » visual/html toggle no longer works in 3.3

  • Since installing 3.3 I’ve lost the visual/html toggle on everything. Deactivating all extensions makes no difference. I’m new to this, and stuck
    I’ve read the troubleshoot post and seen nothing to help.

Viewing 15 replies - 31 through 45 (of 45 total)
  • Ahhh, the Memory limit solution….. 😉

    I think it’s about time the WP people update the recommended solutions list. Far too many potential solutions spread here, there and everywhere

    Didn’t work for me though.

    try this one here at the same time

    define( ‘CONCATENATE_SCRIPTS’, false );

    and have plugins like google libraries and hotfix installed. don’t forget to clear your browser cache and if it doesn’t work, export your database and your wordpress stuff and redo the complete site ( that’s what I did before it worked again)

    Could you explain why the concatenate idea should work?

    I’m sorry I can’t. It’s one of the things that someone tried and posted it here in the forums.

    Did you try a complete new install and only working with the basic plugins and themes? Also please call your host and complain about speed, because if you are on a shared server it might affect your memory too and wordpress might be running slow. Did ou notice any changes in speed?

    Hi Sebaztian,

    My install works. It’s just (as I posted before) that I had to define the language as English rather than German. The problems only appear when it’s defined as German. Change to English and everything works fine, no other change needed (although my memory_limit was by default set at 90 Mb and this could be one reason why it works – Am trying to get the server people to change it to 128 to see if it makes a difference, can’t unfortunately change it myself).

    All the same, the point is this: WP 3.2.1 – everything working fine. WP3.3 – headaches. Anyone new to WP will get turned off by such headaches, just like I got turned off by SilverStripe (it took six months just to install it). I really hope WP solve the issue.

    By the way, “concatenate” made no difference. It really is only the language thing for me…

    Same issue here, but without upgrading. Visual editor was working fine with WP 3.3.1 and a premium theme. I can’t see what i’ve changed on my site… Same theme, no modifications on the active theme, no new plugin. The visual editor just vanished. The visual tab is still active but there is no buttons and text color is white.

    What didn’t work : emptying cache, disabling all plugins, using google libraries plugin.

    What did work :
    Switching to Twenty-eleven. Editor is back. Well, seems to be related to the Premium theme. But it worked perfectly till now… and i can’t use the default theme. So i came back to my theme. No editor …

    What did work too :
    My wplang in wp_config is french (fr_FR). I switched it to default english (no language defined), and the editor is back. But i can’t use my language… I saw in the firebug console that en.js in tinymce folder couldn’t be found. So, following an advice on this thread, i renamed wp-langs-en.js in en.js. Works ok in default language configuration (and with en_EN). Seems logical to me. Back to fr_FR … No editor …

    What i cannot understand is : if it’s related to a js language file in tinyMCE, why switching to twenty-eleven solve the problem ?

    So, i’m looking for a way to use my language … If anyone find out …

    Hi Ouranos2

    Sympathise with your problem as for me the problem persists only when my language is defined as German. Back to English, no problem. However, I tried various languages and one of them was French and it worked fine.

    The problem is 3.3.1 and language. 3.2.1 and German worked fine. Only the update was when the problems started. However, the problem (at least in German) is not just confined to the viz editor but also knocks out some of the blog feeds (the rss feed stops working).

    I thought I had changed my memory limit to 90MB. IN fact, I am stuck at 32MB and can’t change it because my provider would only allow this if I get my own dedicated server (which is far too expensive, plus is overkill).

    From good sources, I have heard that it is in fact down to a memory problem and that WP programmers are aware of the language file issue and (so they said) are nonplussed as to what is causing it.

    It’s still wait and see at the moment.

    Lernerleben, thanks for your help.

    But there is some things that seem very strange to me, about your suggestions.

    – My memory limit is 512 Mo, says my phpinfo and my host.
    – Turning off all plugins didn’t change anything. Shouldn’t this action resolve the memory limit problem ?
    – No visual editor problem in fr_FR with the default theme, twenty-eleven, just by switching theme. Perhaps the default theme is less demanding for memory, but 512 wouldn’t be enough ?!
    – What theme are you using ? Did you try with twenty-eleven ? I use a premium theme, and when the theme is active, i’ve got javascript issues in my firefox console. I should try with other premium theme …

    If you want to test your site on my host, with the 512 memory limit, by cloning it, ask for it, i will open you an FTP account. Give me an email.



    Hi François

    The memory problem is what most people have been saying it is. I find it logically difficult because it doesn’t explain why 3.2.1 works fine (same plugins, theme, etc) and 3.3 breaks. I have a premium theme but will be changing to another one soon.

    WP have recommended seeing if the problem is theme-based by switching to 2011 and seeing of problem persists. I tried it and the problem was still there.

    My “fix” has been to define the language as English and manually translate and ftp my theme files so that everything appears in German. Kept a copy of the originals should WP manage to sort the problem.

    Thanks for the offer of testing your site but I have enough to do to get my head round the new theme I’ve bought 😉


    I have tried all of the suggestions apart from a rebuild which loathe to do so including;
    – Disabled/removed plugins
    – Added define (‘WPLANG’, ‘en_EN’), define(‘WP_MEMORY_LIMIT’, ‘128M’);
    define( ‘CONCATENATE_SCRIPTS’, false ); to wp-config
    – Clearing cache
    – And eveything else read which I have forgotten.

    Strangely enough the Visual Editor is there on IE9 but not Firefox, Chrome or Safari.


    It is always best to start your own thread instead of tacking on to an old one.

    Strangely enough the Visual Editor is there on IE9 but not Firefox, Chrome or Safari.

    If the Visual Editor works in IE but not the others, it is not a wordpress problem. It is a javascript problem with the browsers. Check your java here, and if you want to report back, start a new thread.


    Hi everyone,

    @kmessinger – unfortunately, this isn’t an old thread, the problem still persists. I think MarkHedley’s post is just a new variant on the theme. I take your point about starting new threads but there is a danger that everyone will reinvent the wheel. I wish there was one particular thread or – better still – a document where we could all enter the various solutions tried.

    My update on this is that the general consensus is that there is a memory problem going on, which in particular is widespread amongst customers of the provider 1&1 (also known as United Media), which stops the memory_limit at 32 mb. There is a plugin you can try that can see exactly how much is being allocated to you (often far less than what the provider says)
    I did it and found that my system only allowed 30 mb, even though I’m supposed to have (phpinfo) 90 mb. The performance improved when I deleted certain plugins. But still the problem is only WP in German and English works fine.

    Hi Sebaztian,

    I have experienced problems and all of the solutions offered didn’t work. What DOES WORK for me is to change the WordPress language define settings in the wp-config.php file. My problem was that my install language was defined as German and it caused problems. The moment I defined the language as English (or any other language apart from German), the problem went away. As far as I know, there is no language defined in the usual wp-config and so the system defaults to ENglish (I could be wrong).

    Go into the wp-config file and insert:
    define (‘WPLANG’, ‘xx_XX’);

    changing xx_XX to the language you want. If there are problems change it to ENglish (en_EN)

    You can see your language setting here:

    According to sources, WordPress is aware of this and is looking into it.

    Hope it works for you!

    Did work for me. Not only repaired my visual editor but my change header problems as well.
    Thanks so much!



    Hello all,

    Even i was facing the same problem , i was using stripefolio Template …. i just removed that theme and installed Twenty Eleven theme my problem solved ….

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘visual/html toggle no longer works in 3.3’ is closed to new replies.