Support » Fixing WordPress » visual/html toggle no longer works in 3.3

  • Since installing 3.3 I’ve lost the visual/html toggle on everything. Deactivating all extensions makes no difference. I’m new to this, and stuck
    I’ve read the troubleshoot post and seen nothing to help.

Viewing 15 replies - 16 through 30 (of 45 total)
  • I noticed that I loose the Visual/HTML tabs when I’m in a lower bandwidth environment. Same for both Safari/Chrome on Mac OSX Lion. So when I’m mobile on an air card I loose it, when at home on broadband it’s there. Or maybe it’s just the carrier, AT&T? I’ve had similar problems before with other aspects of visiting a WordPress site from the client side when on my CDMA air card.

    I just tried the “use Google libraries”. It made no difference. Firefox doesn’t work for me, either. I am a Mac user. Also tried the browser cache thing. No joy.

    My issues seem to be not just the missing visual editor but also the plugins, incoming links and WordPress blog links throwing up a simple pie out of memory error. Increasing memory to 64m solved the plugins problem but not for incoming links and WordPress blog.

    My problem is not “Life threatening” so am not going to mess my site up by switching off all my plugins. I would recommend to anyone to make a mirror of your site and database and create a new subdomain to test it. That way you can play with the test site until you find out exactly what the problem is and your normal site is left alone. Unless someone finds a solution in the meantime, I will do just that over Christmas.

    My last WordPress version that worked just fine was 3.2.1. The automatic upgrade to 3.3 was when the problems started. Ergo, my first task with my test site will be to try to revert to 3.2.1. If that doesn’t work, then I will go for other options.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    I noticed that I loose the Visual/HTML tabs when I’m in a lower bandwidth environment.

    mediabaron … Wow. I wonder if you just nailed something.

    See, I know that comcast recently had a case of the galloping stupids and goobered up SVN so no one could pull plugins from it. I wonder if this is related that a provider is caching.

    Ok I found a temporary work around. Not a good one but it works. Seems there is a problem with the .htaccess file. If I rename the .htaccess file to ‘htaccess’ (without the dot) the visual editor works but in order for the edit to work I have to rename the htaccess file back to .htaccess. So I’m guessing this is a wordpress problem in that I know WordPress needs to write to the .htaccess file in particular to edit the permalinks. Is there an easy way to downgrade to 3.2? I know I can just copy my wordpress files from an older version but I think there is some database stuff that happens with 3.3 so I’m not sure this can be done without making some changes to the database.

    Tried a test version of my site and swopped the wp-admin 3.3 for wp-admin 3.2.1 and it didn’t work. In fact it got even worse. Returned to original state without problems.

    The missing visual editor problem in my case is not consistent. Some pages/posts are fine, others only the whited out html pane is available, others I get an “out of memory” error and for one or two I get absolutely nothing, just a white page. However, all pages are available on the public site as before. The problem is only confined to the admin. I believe that certain pages/posts have been “corrupted”.

    Removing the dot from the htaccess file is not the right way as it contains (at least in my case) the rewrite_module command.

    Tried deactivating plugins and then reactivating them one by one.

    Interestingly, the visual editor returned. I then reactivated the first one (Ajax events plugin). Visual editor there.

    The next on the list was Akismet. Then it stopped working. NO attempt to remove folder, clear cache, deactivate all again made any difference. In the test site now ALL pages/posts are missing the visual editor. Just as well it’s only the test site.

    Found other posts in which they say set the language in wp-config if it is not set (or set to default ENglish), messing round with the tinymce.js config file. None of them work.

    Just noticed that all new posts/pages have the visual and HTML editor. It seems only old posts/pages are affected. Hope it holds.

    Are there any news on this?

    I’m using a fresh install of 3.3.1 with a new database and the 2 standard plugins after I experienced issues like no visible words in the visual editor or no access to the visual editor at all, and no window for featured image etc.

    It sounds like a javascript problem since all javascript things have issues, but I’ve tried everything that was suggested here:

    1. unchecked the profile thing that says disable visual editor, which was never checked, so I checked and then unchecked it after
    2. installed google libraries plugin as well as hotfix 0.8
    3. switched themes and cleared cache
    4. updated chrome
    5. cleared browsing and cleared cached on mac under library/cache about 30 times

    I’m starting to become really desperate since I’ve spend now 4 work days on fixing this issue which affects all of my wordpress installations and I have no idea what to do anymore.

    Any help or advice is highly appreciated!

    Have you tried using Firefox Sebaztian? The issue remains for me only under Safari.

    Hi Sebaztian,

    I have experienced problems and all of the solutions offered didn’t work. What DOES WORK for me is to change the WordPress language define settings in the wp-config.php file. My problem was that my install language was defined as German and it caused problems. The moment I defined the language as English (or any other language apart from German), the problem went away. As far as I know, there is no language defined in the usual wp-config and so the system defaults to ENglish (I could be wrong).

    Go into the wp-config file and insert:
    define (‘WPLANG’, ‘xx_XX’);

    changing xx_XX to the language you want. If there are problems change it to ENglish (en_EN)

    You can see your language setting here:
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    According to sources, WordPress is aware of this and is looking into it.

    Hope it works for you!

    Hi guys! Thanks so much for your suggestions. I’ve tried safari, firefox and chrome and also the language thing in the config file on my previous attempts. It just didn’t fix anything which is so incredibly frustrating. Not only can’t I click on visual anymore, the whole button bar is gone. When clicking on featured image within the edit post window it opens a new window and not the pop up with the dark background.

    Empty your cache by going to menu Safari>Empty Cache.

    I just had this problem yesterday where the Visual/HTML tabs wouldn’t show-up. I Emptied my cache and it came back.

    Hi Sebaztian,

    Shame it didn’t work.

    Do you have the possibility of rebuilding your site and only installing WP 3.2.1. Basically, the problem only arose with 3.3 onwards. Unfortunately, it’s too late for me to go back to 3.2.1 (I tried, it didn’t work, I think the database had been updated). But my problems are not as big as yours.

    If you could export your pages/posts through WP (but not the settings) and save your images, then create a new folder for the WP install and create a new MySQL database, download 3.2.1 from WP (release archive, look for 3.2.1 just before “3.3.IIS”, don’t download a beta) and manually install everything, then rebuild your website, it should work. You might have to reinstall all your plugins, perhaps you could just ftp them over?

    A pain, I know.

    Yeah, try what media baron says first. When you changed your language settings did you reset your browser settings (clearing my safari cache didn’t help, resetting everything did)

    Everything is working for me now again. What actually helped was the following change in the config file:

    define(‘WP_MEMORY_LIMIT’, ‘128M’);

Viewing 15 replies - 16 through 30 (of 45 total)
  • The topic ‘visual/html toggle no longer works in 3.3’ is closed to new replies.