WordPress.org

Support

Support » How-To and Troubleshooting » Visual v. HTML Entry

Visual v. HTML Entry

  • Suddenly after re-installing version 3.3 I can’t enter posts in Visual mode. The tab is greyed out and doesn’t allow me to even choose it, so my content must be entered in the HTML tab. I have reinstalled automatically twice already. The first time I installed it everything seemed to be working fine. For some reason I reinstalled –I think because I’d forgotten I had– and it’s not working now. I cannot access any of the buttons that allow you to format text. They do not appear as toolbars at all because the Visual tab is not accessible and functional.

    I must note that I have two WordPress.org sites and I just installed version 3.3 and the visual tab is fully functional, the toolbars are present and when I type and format in that tab it shows in HTML in the HTML tab. Not so with the other site where I am typing text directly into the HTML tab.

    What could be the problem?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Sounds like a Plugin conflict with WP 3.3. Try disabling your Plugins to see if you get the Visual editor tab back.

    If this does not work then revert your theme to the default as well as disabling your Plugins.

    I had this happen to me while on an aircard. The Visual/HTML tab came back when I got back to a broadband connection. I think something doesn’t get loaded properly in low bandwidth situations. I’ve seen this happen before with other aspects of WordPress.

    None of this works for me.

    I logged in using Safari –I normally use Firefox– and low and behold the Visual Editor tab is present and functional.

    This is obviously my interim solution because I have to be able to update my site, but how can the upgrade kind of work on Firefox (remember it works on my other site just fine) and completely work on Safari.

    Are there any Word Press developers or members of the support team who track and address what is obviously a pretty common problem?

    Odds are, its you.

    That is, if Firefox is acting up, then somehow Firefox has the old javascript cached. This has happened to a few people. Try flushing the cache, all of it, in FF.

    Ok, that’s what I was thinking. It’s still so strange that one site works perfectly in FF and the other doesn’t. I will try clearing the cache again.

    Thanks.

    Hi
    Glad I found this thread! I cant get Visual or Html view to work at all. It’s blank. If I ‘ctrl + a’ then I can see content I’ve written but obviously that’s impractical for publishing and writing new posts.

    I’ve tried it in Firefox and Chrome, no joy. Also cleared my cache in both browsers, no joy. I’ve deactivated all plugins, swapped to default theme, no joy. Swapped back to my theme, still no joy.

    In my control panel, which php file contains the code that puts the visual/html dashboard back as it should be? I may have deleted it by mistake?

    Keen to hear from the codex community!
    Waggy

    esmi

    @esmi

    Forum Moderator

    Please post your own topic.

    I have now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Visual v. HTML Entry’ is closed to new replies.
Skip to toolbar