Support » Fixing WordPress » Visual toolbar not showing all the buttons.

  • Resolved ryanmc


    I apologize if this has been asked before, I tried searching but could not find a solution for my particular problem.

    I have just newly installed WP 2.5.1. This is not an upgrade. I also installed several plugins like WPG2 (embedded gallery), Akismet, AddThis Social Bookmarking Widget, Subscribe2, and Subscribe To Comments.

    When I go to write a story I can see the Visual and HTML tabs. When I choose the HTML tab I see a lot of buttons in the toolbar for things like bold, italics, links, etc. However, if I click on the Visual tab I only see three buttons in the toolbar, they are Insert More Tag, Show Hide Kitchen Sink, and Gallery Images. I should be seeing a lot more like Bold, Italics, Spell checking, etc. At least I assume I should see more because the screen shot at shows a lot more options , you may have to refresh the page until the image of the editor appears.

    Does anyone know how to turn on the additional buttons?

    Everything else works fine I can still enter text and save and publish in the visual editor.

    I can include Screen Shots if you need them.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Here is a screenshot of the toolbar that I see

    im having the same problem, could not find my subscribe2 button…. have you figured it our ryanmc…

    anyone able to help?

    I am also having 2.51 toolbar problems. My business blog at has a 2 line toolbar, complete with spell check.

    my daughter’s blog only has b i link b-quote code ol ul li

    Yes I have emptied the browser cache, cookies, and the ashtray. Same for firefox or IE.

    Any thoughts would be great.

    Moderator kmessinger


    Deactivate all widgets and see if it works. If not, leave the widgets turned off and use the default theme to see if that works.

    I deactivated all my plugins, cleared my cache and did a force refresh. No toolbar. So leaving plugins disabled I switched to the default template, cleared the cache and did a force refresh. Still no toolbar.

    Moderator kmessinger


    Have you tried a different browser like FF?

    I have no plugins or widgets active
    Default theme in use.
    no toolbar.
    i’ve even done a re-upgrade of 2.51

    something is wrong beyond the easy answers.
    thanks for the help.

    Moderator kmessinger


    Please read this
    There is some good advice here about caches.

    Pay paticular attention to the part about reloading wp-includes and wp-admin. You must delete these in an upgrade not just copy over. Do not delete wp-content.

    I found this piece of code in my webpage

    // <![CDATA[
            if ( typeof tinyMCE != "undefined" )
        // ]]>

    When I use firebug to change the “none” to “block” all the buttons show up.

    This code doesn’t make any sense? It says hide the buttons if tinyMCE is anything but undefined.

    Ok I did a little more digging. I found that the code is inserted by a function called the_editor

    <?php the_editor($post->post_content); ?>
    in edit-form-advanced.php line 198

    But for the life of me I cannot find where that function is defined, I have done a full text search of every file in the wordpress directory. I only know that if I comment out that line the editor goes away and so does that code.

    If someone who knows wordpress better than I can help me find the_editor function I would appreciate it.

    Nevermind, I found it. I guess I have not synced my hard drive all the way. Anyways, I also found the code
    in general-template.php line 958

    but now I am thinking that these are the wrong buttons because they don’t look anything like what I see on the front page of the website and I still don’t have a spell check button.

    Here is a picture of what I see

    Here is a picture of what is on the wordpress website

    So back to square one. Any help would be appreciated.

    Sorry I messed up the links above. I wish I could preview posts before I send them.

    Here is a picture of what I see

    Here is a picture of what is on the wordpress website

    First I have to say thanks to kmessinger. I followed your link and suggestion to delete the two folders.

    After deleteing them and reuploading them the toolbar started working. I don’t know why because this was a brand new install, but it fixed it.


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Visual toolbar not showing all the buttons.’ is closed to new replies.