Support » Fixing WordPress » Visual & Text Editor Buttons Not Showing

  • Resolved elesed

    (@elesed)


    I want to be able to edit my posts in the visual editor.

    I’m running WordPress 4.4.2 with the Lifestyle theme, which is a child theme of the Omega theme.

    Everything is completely up to date. Below is an image of what my editor is displaying:

    http://oi66.tinypic.com/10dtzja.jpg

    I’ve installed the WP Edit Plugin (3.7) to try and mitigate the problem but I still can’t see anything.

    I’ve deactivated all plugins and tried logging in in both Chrome and Explorer and none of these change anything. Am I missing something really obvious?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Hi elesed!

    Are you using any browser extensions? If so, deactivate those to see if that resolves the issue.

    Does it happen it you use a core theme like Twenty Fifteen/Sixteen?

    Thread Starter elesed

    (@elesed)

    Hi Jose!

    Sorry for the late reply.

    Yes, it still happens when I use Twenty Fifteen and it still happens when all my browser extenstions are deactivated. It’s really quite bizarre.

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    That is quite bizarre!

    If you open your browser’s console ( usually by using your F12 key ), are there any errors that are encountered?

    Thread Starter elesed

    (@elesed)

    There are quite a few – I’m not sure if I’m doing this right, but I’ve screenshotted them into one image to show you:

    http://oi68.tinypic.com/fvepft.jpg

    I don’t know if that’s the right thing. It’s not showing any errors or warnings otherwise in the top right like it does for other webpages.

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    It does sort of help.

    If you go to the console tab of that it may show you some errors. If it does, copy and paste them here or in a pastebin. It is right next to Sources and Elements.

    Thread Starter elesed

    (@elesed)

    Hi Jose,

    There’s nothing in the console tab at all. It’s also not showing any little icons to say there are errors or warnings like it does when I’m on other pages.

    Thank you for being patient with me!

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    There’s nothing in the console tab at all

    Now, I’m scratching my head over here wondering “what the fuzzy is going with this?”. 😀

    Taking a second look at the screenshot I do see an extra button next to the “Add Media” button. Try deactivating all your plugins one more time to see if this really does still happen. There should be no extra buttons if you have them all deactivated.

    Thread Starter elesed

    (@elesed)

    http://oi64.tinypic.com/2v0lmyu.jpg

    still happening. i tried deactivating all the plugins before but had reactivated them after it didn’t work so that’s why they were showing in the screenshots before 🙂

    is there any way it can be anything to do with the cache? not the browser cache (which i’ve cleared).

    i’m not sure why it’s still doing this!

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Does it also happen in any other browser?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Go to Users->Your Profile.

    Make sure that the box marked “Disable the visual editor when writing” at the top of the screen is not checked.

    If it is checked, then uncheck it and then scroll down to the bottom of the page and click the “Update Profile” button to save your settings.

    Thread Starter elesed

    (@elesed)

    THANK YOU SO MUCH. It’s all working fine now – the “disable the visual editor when writing” box was ticked.

    I appreciate your help, Jose and Samuel!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Glad that worked. Sometimes those hidden settings can confuse everybody. 🙂

    I could not understand why the visual-text tabs worked on one site and not the other; ‘FGS’
    Perhaps we could get a tab that would turn it off/on on the editor. Seems logical to me… but I’m just the average user. Glad the :fix: was here.

    I know this has already been resolved but just wanted to say thank you! In my case, the box marked “Disable the visual editor when writing” at the top of the Profile screen was NOT checked but I was having the same problem with the Visual/Text tabs not displaying. So, I checked the box, saved, then unchecked it, saved again and now the Visual and Text tabs are displaying properly. Feeling very grateful!

    I have the same problem but above solutions do not help in my case. I have deactivated plugins and activated them again, I have checked and unchecked the box, still no solution.

    This is a serious problem, I have installed and deinstalled other plugins with editors to use those instead but they don’t show as well.

    Why is this problem not taken serious and fixed once and for all.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Visual & Text Editor Buttons Not Showing’ is closed to new replies.