Support » Fixing WordPress » Visual Rich Editor – WYSIWYG

  • Resolved Ahhh


    Following the advice of HandySolo with regard to my topic
    and switched of the visual rich editor. I’d been having problems inserting HTML into posts etc. Before s/he replied I’d discovered that at least part of the issues was to do with the Firefox HTML editor that was called from WP, as IE worked “fine”.

    But when I switched off the WYSIWYG function BINGO my icons turned up!! See . I’ve pasted a load of Java errors being reported there so any help on that would be great.

    Anyone any ideas what’s going on here? Surely the icons should be ON for WYSIWYG and OFF otherwise??

Viewing 12 replies - 1 through 12 (of 12 total)
  • Ahhh


    Talking to myself again probably but hey, I must make a note to check for hairs on the palms of my hands later!

    I’ve been playing with themes, installed Kubrick-etc, didn’t rave, tried Classic. Better, the sidebar is consistent throughout as far as I can see (and as any good navigation menu should be IMHO!). I still want to change widths and fonts etc but it’s a better starting place for me – then I noticed: the pluses and minuses are showing now. Coincidence? My host said they’d fixed something to do with hotlinks:

    “It looks like the hotlink protection was causing the problems with your page during reloading. I fixed it by allowing the following URL”

    Don’t know what they mean as yet, and so I don’t know which of the changes caused the icons to reappear. Anyway, one step forward! Thought you’d all be eager to know. ;))



    . . . and I’ve switched back on the Visual Rich Editor thingummy and the icons are still there!!! Whoopee. I’d still like to know what went wrong but I guess that’s one for my alter ego: Don Quixote!

    Ho ho. Many of us have had no answers…dont get depressed and start chewing the walls and jumping on your knuckles!
    Hot linking (I think) has something to do with getting content from another domain or so. I’ve had problems with script redirecting that messes things up in ajax scripts. It seems you can control some of this in your browser. Let it “allow to get content from other sites” or so.
    I’m definitely not an expert, just trying to cheer you up “Don” 😉

    Having similar problems – no icons in the ‘rich’ text editor, just the visual/code buttons – when I switch to code, the window disappears and I can’t switch back.

    It’s NOT a firefox problem – I get the same in IE. Just upgraded to 2.2 from 2.1.3 to see if this would fix it, but it hasn’t.

    This is a massive issue, and it seems a lot of people are experiencing it. What’s going on?

    Any fix for this yet? I have even redownloaded wordpress 2.2.1 and replaced all the files and all i get is the “Visual” and “Code” buttons.

    People over here are suggesting replacing the text editor with a custom plugin:

    This seems like a crummy workaround however, and not a solution – particularly as many of these plugins disable the WP image uploader many of my users rely on.

    Yeah I came across that post, but its not an option to replace the normal one. There has gotta be a real fix for this.

    Anyone have any other insight on this yet?


    This topic is not resolved.

    This seems like a crummy workaround however, and not a solution – particularly as many of these plugins disable the WP image uploader many of my users rely on.

    I just migrated hosts and wake up to no WYSIWYG icons. In fact, there are now no Visual or Code tabs but if I turn off the visual editor I get the html buttons, again, not what I want. I turn it ON in my profile, all buttons disappear. Any ideas out there?



    Running 2.3 beta here and started to experience the same problems…loss of the WYSIWYG icons and left with simply the Visual and Code tabs, neither of which worked. I’d been adding a number of plugins so working backwards, deavtivating one by one, I tracked it down to the AddMySite (AMS) plugin.

    Now that’s gone and I have everything back!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Visual Rich Editor – WYSIWYG’ is closed to new replies.