WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » Visual mode doesn't work after JetPack 2.1.1

Visual mode doesn't work after JetPack 2.1.1

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeremy Herve

    @jeherve

    Could you try to disable all other plugins one by one, to see if one of them conflicts with Jetpack?

    Could you also try to disable Jetpack Modules one by one, so we can find out which one causes the problem?
    You can find out how to disable Jetpack modules here:
    http://jetpack.me/support/#turn-off-jetpack-modules

    It could also help if you could give me more details about the issue. Do you receive an error message when using the Visual Editor, or did it completely disappear from your dashboard?

    Thanks I hadn’t thought to disable the individual Jetpack Modules one at a time. It was the Shortcode Embed Module that was doing it. I was able to keep the rest of the modules active and just deactivate that one!

    I don’t get any error message. The tab for the visual editor is there, it just wont let me click on it.

    I just ran into the same problem, and the same fix worked.
    The problem was that $ was undefined (jQuery was still loaded normally), and so that was breaking part of jquery.ui.widget (when $.extend was called). Not quite sure how $ was ending up undefined.
    Note: $ is still undefined after disabling Shortcode Embed. So while the issue of $.extend being called is eliminated by disabling that module, the issue of $ being undefined is not.

    Plugin Author Jeremy Herve

    @jeherve

    Thanks for the additional details.

    Do you have any other active plugins on your site, that may conflict with the Jetpack shortcodes?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Visual mode doesn't work after JetPack 2.1.1’ is closed to new replies.
Skip to toolbar