WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor WordPress 3.1

Visual Editor WordPress 3.1

  • This morning I upgraded http://corycenter.org to WordPress 3.1 and lost some functionality in the Visual Editor. The Visual Editor does not display the formatting toolbar and the text box is no long WYSISYG, it shows the html. Has anyone else had this problem? I have done the following things and still have the issue:

    – tried different three different browsers
    – deleted cache completely on all browsers
    – deactivated all plugins
    – switched to the Twenty Ten theme to rule out any theme-specific problems
    – checked to see that my user is an admin
    – enabled and disabled the visual editor in my profile
    – manually installed WordPress 3.1

    Any ideas? My content is intact, which is a good thing – but I miss the Visual Editor!

Viewing 15 replies - 1 through 15 (of 27 total)
  • Me too. All of it. At least I’m not just losing my mind. Sorry this isn’t a real answer.

    I’ll add to the list. just updated my sites, same problem.

    I did try to re-install WP 3.1 via ftp. same thing.

    esmi

    @esmi

    Forum Moderator

    Helpful…

    Been there trying that, as have others (found another thread). Seems random things fix some sites and not others.

    The other chunky thread is

    http://wordpress.org/support/topic/missing-visual-editor-2?replies=30#post-1983788

    They should probably be combined.

    Esmi – I went through that yesterday and didn’t see a thing that I hadn’t tried or that seemed to be relevant. The only thing I haven’t done is manually install the fresh down load in its entirety. Where is the TinyMCA stored? It seems to be a plug-in, but it’s buried and not part of the plug-in dashboard accessible group. I don’t know what I hope to find in finding it – nut anyway, have been through the Master List with no good result.

    esmi

    @esmi

    Forum Moderator

    They’re not random fixes. They’re site & server specific.

    Esmi – on the other thread, I told you that I was with Netfirms – does that tell you anything about my server? I’m really kind of stupid about all of this. They would own the server that is hosting me, jah?

    esmi

    @esmi

    Forum Moderator

    does that tell you anything about my server

    Not really. We sometimes to know what kind of server you are using (Windows or Linux) and whether your host uses any specific server configurations that might impact on WordPress.

    The theme and plugins you have installed may also have an effect.

    Okay. This is very frustrating. I’ve asked Netfirms what kind of server I’m on, but have no answer. Does it matter at this point? Is there still a chance that this is a server related problem? I have tried EVERYTHING thrown at me, except for the fix code someone suggested either here or on the other thread. I have tried other themes – it’s not theme specific. I’ve tried the whole plug-in route – it’s not the plug-ins. I even installs Askemet on one of the inactive sites (after manually deleting 650 spam that had accumulated over three years) and it made no diff.

    I’m going to try the fix code. But I keep saying “I’ve tried” over and over again about every suggestion on the master list, and the only answers I get advise me to try those things. Not even try them AGAIN. As if nobody had read the rest of my posts. I’ve tried it all. This is really screwing up my workflow.

    esmi

    @esmi

    Forum Moderator

    Does it matter at this point?

    Yes. Windows servers often create very specific problems when using WordPress.

    Esmi – are you one of the Masters of this program? Or are you just a knowledgeable person. Is somebody actually working on this problem – or are there not enough of us to make more than an insignificant and unlucky few?

    Find it strange I have this problem with one page only, the home page http://stdoa.ca/. Visual editor appears normal on all other pages. Agree with mattguevara and nothing seems to work. What a time waster.

    Hi another 123reg customer here I have a possible solution that worked for me and a few others too.

    Go into Your settings -> General section of your admin.
    In Site URL or Home URL is there a colon ‘:’ ?

    I had one added by 123reg, removing the colon bought back the visual editor.

    For those more advanced users you can check this also through phpMyAdmin. in the wp_options table look for siteurl

    I hope it works for you too

    @themightyant,

    I was also having issues with TinyMCE not showing up.

    Your suggestion fixed it! Thank you!

    achellios

    @achellios

    On the off chance anyone else is still having trouble with this issue, I’ve posted an alternate workaround here:

    http://wordpress.org/support/topic/visual-editor-not-working-mimicing-html-editor-blanking-out-no-tool-bar

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Visual Editor WordPress 3.1’ is closed to new replies.