Support » Fixing WordPress » Visual Editor will not show

  • brianmpenn

    (@brianmpenn)



    I am verily frustrated with this problem. I have scoured the internet for solutions. I have updated the core files, tried numerous plugins, cleared my cache, I am 95% sure that I have found every thread on this site that pertains to this bug and tried every option listed, still to no avail. ever since the 3.5 update my editor has refused to load on ANY browser/platform/network. The only reason I have it working now is because I back revved my WP installation to 3.4.1, NOT my finest moment, but at this point the editor is working.

    I really would like to have an ACTUAL fix for the problem. My gut tells me that it is my host (ENOM/Bulkregister) that is somehow borking my WP install, but without concrete evidence or a tangible diagnosis I cannot even begin to contact support for assistance.

    I’m hoping the collective genius can help me to figure this problem out. Remembering that I have already tried the basics (no plugins, default themes, etc. and so on) and even some of the documented advanced changes such as file editing and reloading, what additional information can I procure to feed the genius and find my solution?

    Thank you in advance for all your ideas/suggestions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Krishna

    (@1nexus)

    Member

    Are you sure that you have not disabled visual editor in your user profile?

    esmi

    (@esmi)

    Can you tell us what you have tried already? Please do try to include as much detail as possible.

    brianmpenn

    (@brianmpenn)

    Things I HAVE tried: (in no particular order)

    • Disabling all plugins
    • Using the default Theme
    • re-installing the core WP files (not wp-content)
    • Clearing my browser cache
    • Different browsers/machines
    • Different locations/networks
    • “Use Google Libraries” plugin
    • Turning on and off the visual editor from the user profile
    • added define( 'CONCATENATE_SCRIPTS', false ); to wp-config

    I think that’s everything, I’ve been wrestling this issue for the better part of 2 months or more. Each of the above items has been tried several times and in various orders or implementation. So far the only thing that has definitely worked is the roll back to 3.4.1.

    Thanks again for your time.

    brianmpenn

    (@brianmpenn)

    As far as detail, there is none. None of the proposed items effected the core problem. Expected changes did occur (plugins, themes) but did not effect the lack of editor. When I turned off the editor in my profile, I could then see the contents of my post as it should appear in the non-visual editor, but re-enabling the editor returned it to it’s broken state.

    mrsreeder

    (@mrsreeder)

    The only fix I have come across for this problem is to use the Google Libraries plug in.

    Sabinou

    (@sabinou1)

    He did try that already, mrsreeder.

    Two suggestions from me.

    – create a new user in the admin with the same rank as your current user, log off, re-log as the new user, and see if the problem remains. A bit more than a year ago, I had the visual editor broken with a user, while a newly created account didn’t have the problem, turned out something got messed up in the database options for the user, I ended up manually cloning, within phpmyadmin open in two tabs, the user options from one user to another. And boom, problem gone.

    – some say that time is money, so if you’ve been spending hours on it already, and you’re pissed off, and ten bucks isn’t much for you, how about you try your blog on another web host, just for a couple of days ? Create yourself a godaddy hosting account – just kidding, go for hostgator or any other quality host, godaddy isn’t worth it – upload a clone of the blog to the new hosting account, change the domain nameservers in your registrar’s options, come back 24 hours later when the change is effective (or use whatsmydns.net to see if the change has propagated to you already, or update a little something in the blog’s template to see which version you’re seeing, whatever works).
    And there you are, you can see, in exchange of 30 minutes and probably ten bucks, if this was related to your web host.

    brianmpenn

    (@brianmpenn)

    I think I tried the ‘user’ trick, but will do it again, because I can’t remember for sure. As far as the secondary hosting thing… I’ll have to think about it. Do you think a LAMP virtual machine with a copy of the site on my local LAN be a valid test?

    Sabinou

    (@sabinou1)

    While a LAMP virtual machine could run your blog, you’d have adjustements to make to have it work locally, and that doesn’t tell you it would work with another web host.

    But, hey, sure, you can try it locally. I’m not familiar with the adjustments to make to have a blog configured to be online work locally, so it would take me longer than setting it up with another web host, haha ^^ If something is definitely broken inside the blog, it will also be also broken locally.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Visual Editor will not show’ is closed to new replies.