WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Visual Editor (TinyMCE) not showing up on 2.9.2 (Linux)

[Resolved] Visual Editor (TinyMCE) not showing up on 2.9.2 (Linux)

  • I downloaded the ZIP file for WP 2.9.2 to my Windows PC. I then unzipped it using WinRAR. I get 753 files. I uploaded them all to the Linux server via FTP.

    Yet I cannot see the Visual (TinyMCE) editor.

    I am logging in as Admin.

    I do not have visual editor disabled in my user profile.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have done the following with no luck:

    1. Disabled all plugins.
    2. Used the auto-upgrade feature to reinstall 2.9.2.
    3. Deleted the browser cache for this site (I use the latest Firefox)

    Also, perhaps not coincidentally, I just now tried to turn on Gears (Turbo), and I get an error that pertains to tinymce/plugins/…

    Here is the full error message:

    Turbo: Gears Status

    Gears is installed and enabled on this computer. You can disable it from your browser’s Tools menu.

    If there are any errors try disabling Gears, reloading the page, and re-enabling Gears.

    Local storage status: Error: Download of ‘http://wvupci.com/wp-includes/js/tinymce/plugins/fullscreen/fullscreen.htm?ver=327-1235’ failed, status code 404.

    esmi

    @esmi

    Forum Moderator

    I then unzipped it using WinRAR. I get 753 files.

    Did you retain the folder structure? Have you tried:

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    increasing your available memory?

    I found this page with info that indicates I should have a js page at:

    [your site]/wp-includes/js/tinymce/tiny_mce_config.php

    It says that page should display as text if I browse to that URL.

    I get “Error 404 – Not Found” if I try that, and I also cannot find such a file inside my WP files using FTP, and I also cannot find it in the original Zip file of WP 2.9.2

    Anyone know anything that could shed some light on this? Thanks!

    ESMI:

    Did you retain the folder structure?

    I retained the folder structure. I pasted it all up via FTP at a single motion. I took note of the file count to make sure all files made it onto the Linux server.

    Have you tried:

    – switching to the default theme to rule out any theme-specific problems?

    It’s a new install and I’ve never left the default theme yet.

    – resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    I can try deleting all the plugins. Will try that next.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    I refreshed the whole install via the auto-upgrade feature. If the above plugin delete does not fix things, I will move to manually deleting and replacing wp-admin and wp-includes folders from a fresh download of WordPress

    – increasing your available memory?

    I am on a hosted Linux server on GoDaddy.com, and I have several WP installs working great on the same hosting and this has never been a problem. I don’t know how to increase my available memory in this scenario, and I am not sure I am allowed to do so.

    Thanks for your tips. I will report back! 🙂

    FOUND THE PROBLEM! FIXED IT!

    Thanks for your help.

    Here was the issue.

    One of the plugins, called WP Secure, placed an .htaccess file into the wp-includes folder.

    That file’s settings were preventing certain files from being accessed, and thus both the visual editor on the post page, and the Gears option (Turbo), were being blocked.

    As soon as I deleted the .htaccess file, the problem went away.

    Ideally, I would like to have both proper security, and not lose core functionality. I simply don’t know enough about how to edit an .htaccess file to get anywhere with that.

    Thanks again for your help!

    PS: Now, even after the problem is found, and all is working fine, this page:

    [WP Site] /wp-includes/js/tinymce/tiny_mce_config.php

    Still does not exist. Must have been applicable to an older version.

    Doug,

    I spent hours troubleshooting this same problem – then finally found your post, deleted the .htaacess file created by WP-Secure in the wp-includes folder – and problem solved – THANK YOU!

    Glad to have been a help.

    Sounds like I’m following in the footsteps of others (looking for that tiny_mce_config.php file, re-uploading files etc) but I do not have a plugin called WP-Secure and there is no .htaaccess file.

    After working on this for hours I uploaded a completely fresh install onto a different web-site (2.9.2). I have added nothing on the site — no posts, no plugins. I have deleted ALL plugins (there are two that are not active on install which are now removed). I have cleared my cache in both Firefox 3.5.5 and Safari 4.05.

    The visual editor tab is visible. It even shows as highlighted when you go to the edit page but there are no buttons and it shows up with the buttons that show on the HTML tab. Clicking on the html tab keeps the screen identical and flipping back to the Visual tab leaves you with a text box with no buttons whatsoever except for the video, audio, media buttons.

    Any ideas?

    I read your post. Don’t know the answer. Just wanted to let you know it’s not being ignored. I just don’t know enough to help. Sorry.

    I’ve upgraded to 3.0 and I’m having this problem. I have no .htaaccess file to delete. All plugins are deactivated, cache has been cleared, default themes have been tried. I’ve tried the solutions that seemed to work for people on older versions of WordPress, but no luck on my end.

    I had this same Visual Editor problem a couple months ago, and I ultimately changed hosts to Hostgator and the problem seemed to go away. That is until I upgraded to 3.0.

    I’ve seen pages of posts of similar issues with different solutions that seemed to work for some people. It looks like this is a problem that has gone on for more than a year with no set solution.

    It looks like all the users of WordPress are doing their best to help each other figure out this problem, which is awesome, but the developers aren’t paying attention.

    Same problem,
    upgraded to 3.0 from 2.8.x, html editor is not working, I don’t see the switch button at all, is there any configuration to enable?

    Hi,
    same problem here. But, with a twist.

    After upgraded to 3.0 the editor lost the buttons.

    The strange thing is, all the buttons are working well under win+ff or win+ei8 but no buttons under mac+ any browser (ff, safari, camino, chrome). How could it be?

    It is really hard, ’cause I am usually working on my post at home (workplace for work) but after the upgrade I have to stay at my workplace and use windows if I want to write a post. I am not happy.

    The whole upgrade went seamlessly and the face of my blog is still the same.

    I’ve tried everything but the thing is – it is working under win xp so I don’t want to mess up with the config files or php. (and I am not a programmer )

    I had this wp upgrade and Mac OS X update as well (to 10.6.4).

    Now, all I suppose to say: help, please.

    Thank You

    Well, my problem is a slight bit different. I have 3.0 wordpress or whatever the newest is. I have had this site up for 3 months with (go daddy) I uploaded a small site to my host account (go Daddy) and went to do some editing on my site and clicked on recommended reading and got an whoops message. Go daddy no help they say that the server trying to find the file but it is not there??? Also when I write a new post publish it want to take a peek at it and I get a error message. I can see the post if I click on my site name but no other way. I am finding I cannot link to my pages anymore either I keep getting error messages.. Can anyone help me??????
    Frustrated Kimberly
    http://www.1clickfindit.com problem site

    Oh yeah and my gravatar is not working anymore

    sorry I forgot to add that problem to my post.

    Kimberly
    from 1clickfindit

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] Visual Editor (TinyMCE) not showing up on 2.9.2 (Linux)’ is closed to new replies.
Skip to toolbar