Support » Fixing WordPress » Visual editor text not visible – displays html when highlighted

  • I recently updated WordPress to version 3.2, and at the same time I also updated my theme (Graphene).

    Now when I go into to add a new post, or edit an existing post the visual editor is not working properly. The text is not visible, but when the area is highlighted it displays as html.

    I only have one plugin installed but I have deactivated this, and also cleared my browser cache (as advised in similar threads) but nothing is working.

    Any advice would be much appreciated.

    Many thanks

Viewing 15 replies - 1 through 15 (of 18 total)
  • I got same problem at my But I was solved. I do this :

    – Clear my application cache with CCleaner (googling and free download) because i used Win7. You can try skip this if you not win os

    – You MAY need to delete the wp-includes and wp-admin folders and copy them up again fresh from your WP 3.2 manual download.

    – Clear my browser cache and everything.

    Voila.. my problem solved and good run with WP 3.2

    I am having same issue, along with other issues (can’t click on html button in visual editor, can’t click on links for ‘status’ and ‘visibility’.

    I’m wondering if its jquery related…

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    If that doesn’t help, try reverting to the Twenty Eleven theme.

    Many thanks for all the advice.

    I am using a free WordPress app provided by my host so I haven’t downloaded anything manually – WordPress was set up automatically for me. I can still access the files through ftp so I couple try and replace the wp-includes and wp-admin with a back-up version.

    I have tried reverting to the TwentyEleven theme but the same thing occurs.

    I’m not sure what a jquery is…

    If all else fails I might need to install WordPress myself and hopefully I can just replace the wp-content folder to get all my posts back?

    @thehungrygannet – your posts are in the database, not the wp-content folder. That only holds your themes/plugins/uploads. If you haven’t touched the database, then it should still contain everything.

    I’d double-check how your host does the wordpress re-install tho – you don’t want it either creating a new database or erasing your old one or you WILL lose all your old posts.

    These are the most common reasons for the visual editor to stop working:
    – cache problems (in the browser or on the network). You can try force-refreshing the page by holding CTRL or Shift.
    – Javascript errors, in 3.2 these can be caused if your theme or a plugin loads an older version of jQuery.
    – failed update, in rare cases not all files are uploaded or replaced correctly. You can try deleting wp-includes/js directory or the whole wp-includes, and upload a fresh copy with FTP (to get that fresh copy, download the file and extract it. That directory is in it).

    Thanks very much for your help.

    Unfortunately I think I managed to mess things up even further last night before I read your advice.I deleted my wp-content and wp-admin folders and replaced them with my back-up versions (these are the only two folders I have back up copies of).

    Now I cannot get into my WordPress admin at all. When I log on (the page looks very different) I get a screen which says

    Index of /foodblog/wp-admin

    Name Last modified Size Description
    Parent Directory –
    maint/ 05-Jul-2011 21:00 –
    wp-admin/ 06-Jul-2011 09:09 –
    Apache Server at Port 80

    I think I may have messed things up beyond repair now…should I just scrap it and start again from scratch? I have my database backed up so good to know that this is where my posts are held!

    Many thanks!

    see my post;

    i’m getting the same errors in an untouched (not upgraded) 3.14 wordpress, after I did the PHP upgrade. the javascript is all generating errors ‘illegal character’ – in both 3.2 and 3.14 admin panels.

    This is all a bit beyond me – I seem to be digging myself a deeper and deeper hole.

    I deleted my wp-includes folder but now my entire website fails to work and I get the message:

    Warning: require(/websites/123reg/LinuxPackage21/th/eh/un/ [function.require]: failed to open stream: No such file or directory in /websites/123reg/LinuxPackage21/th/eh/un/ on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/websites/123reg/LinuxPackage21/th/eh/un/’ (include_path=’.:/usr/share/pear:/usr/share/php’) in /websites/123reg/LinuxPackage21/th/eh/un/ on line 21


    It looks Ike you deleted the wp-admin and other folders, but didn’t put them back. The ‘index of’ message above is because there isn’t any files in that folder. Make sure that wp-admin, wp-includes, wp-content, etc all have files in them.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    thehungrygannet – Just copy the folder back up. is the install and you can grab frsh copies from there 🙂

    Success! Thanks Andrew Ozz. I was having the same problem seeing the full visual editor too, and nothing I did with my theme or plugins made any difference.

    In the end I just deleted the wp-includes/js directory & uploaded a new copy via FTP. Everything is working fine now… phew.

    A developer told me this and it worked:

    Download CKEditor. It works. I have a new and improved visual editor!

    And I don’t have a clue about this code stuff.

    Thanks to everyone for their help! Thankfully I managed to find someone to sort out my website so fingers crossed all is well. I’m not cut out for this technical malarkey!

    Checked out the CKeditor though – it looks great! Thanks for the recommendation.

    @andrew Ozz (azaozz) and @minamitek – I just want to thank you both for the responses you shared. I can confirm that deleting the wp-includes/js folder and uploading a fresh copy of the WordPress source files did the trick!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Visual editor text not visible – displays html when highlighted’ is closed to new replies.