Support » Fixing WordPress » Visual editor suddenly not working

  • Resolved Frances Allen

    (@frances-allen)


    I hit this problem a week ago – suddenly I could no longer use the visual editor.
    I can think of nothing that I had done which could have prompted the problem. I can only text edit my blog, which for someone one step up from novice is a nightmare. It is happening on both Mac and iPad (both running up to date software).
    I have done as much as someone at my level can – emptied caches, deactivated plugins, changed from elderly theme to 2016, added define('CONCATENATE_SCRIPTS', false ); to wp-config.php
    The only other information that might be relevant is that I’m on shared hosting at Greengeeks.

    I know this problem has been discussed before https://wordpress.org/support/topic/visual-editor-broken-after-upgrade-to-wordpress-4-7/ . But it was marked as resolved, which is why have reopened the subject.
    I would welcome ANY suggestions provided they are appropriate to my level of competence!

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you tried disabling all plugins and activating a default WP theme then it might be that there is some issue in the WP files.

    Try forcing a WordPress reinstall. Go to /wp-admin/update-core.php and click the “Re-Install Now” button.

    Thank you for this suggestion – and for very helpfully telling me where to go.
    I’ve reinstalled. The problem is still there. Clicking on the visual button does nothing. However, I do notice that if I go back to text, this still works, whereas earlier trying visual and then returning to text meant neither worked.

    Any more suggestions guys?

    Hi

    Try

    define('CONCATENATE_SCRIPTS', false);

    in wp-config.php.

    And use dev tools in your browser to see if the file http://example.com/wp-includes/js/tinymce/tiny_mce.js is being loaded. See Firefox (or Firebug) or Chrome or Safari or IE

    And also check to be sure a security plugin did not leave an .htaccess file in wp-includes which will prevent access to that file wp-includes/js/tinymce/tiny_mce.js
    Thanks
    Ahir

    Thank you.
    I had already added the line to wp-config.
    There are no stray .htaccess files in wp-includes.
    However, I dont really understand what to do with your second point. If I click on this link it simply downloads tiny_mce.js to my Mac.

    Any more advice what I should do? This is driving me nuts. I have no interest or skill in looking inside the works. I just want wp to work as it has, smoothly, for over two years.

    • This reply was modified 3 years, 4 months ago by Frances Allen.

    Ahir
    I’ve just clicked on the link http://example.com/wp-includes/js/tinymce/tiny_mce.js as you suggested and di inded get the attached error message, which means absolutely nothing to me.

    I dont understand if there is a directory example.com on my site – I dont see to have this. Don’t know whether it makes any difference that my wp files are not at the top level, ie they are at http://francesallen.com/wp/

    Anyhow, here are the errors in case you can throw light on what to do next.errors

    • This reply was modified 3 years, 4 months ago by Frances Allen.

    Hi

    Sorry for that but I had given you just example where example.com is your domain name.

    Dumb me! Sorry, that shows you the level of my competence.
    OK I have retried with http://francesallen.com/wp/wp-includes/js/tinymce/tiny_mce.js (my wp is in a folder, not at top level) and got file not found.
    This is not surprising because I see that there is no such file in the tinymce folder. I downloaded a fresh copy of the folder this morning and this is what it contains Hopefully I downloaded the correct folder?

    I have the same issue tinymce.php does not exist even in the standard download of WordPress 4.7.4 (off the website) it has a wp-tinymce.php, though.

    I checked in the backup I made before installed all the updates 2 weeks ago and it also
    does not have tinymce.php.

    I have tinymce.min.js (not tiny_mc.js) and wp-tinymce.php (not tinymce.php).
    Here are the latest errors that come up when I open a post to edit.
    I have now updated wp 4.7.5. (GB version) twice. I have changed to the theme 2016. I have deactivated and reactivated plugins many times. I have added define('CONCATENATE_SCRIPTS', false ); to wp-config.php. It looks to me as if file permissions are OK (eg mouse.min.js is 644).

    Before all this started I had been doing nothing other than writing the odd blog post, Now I see the probem is more widespread than visual editor. I can’t upload images to envira gallery as half the buttons are invisible or not working! I’m sure the two problems are related. I could sure do with some ideas.

    • This reply was modified 3 years, 4 months ago by Frances Allen.

    Just to let people know, the problem has been resolved. After lengthy exchanges of emails with the support team for my web hosts, they advised me to try deactivating Cloudflare.
    It worked. Phew, I have got back properly functioning Text and Visual editors again. Thank you to those who offered help on this forum. I appreciated this generous support.

    YES! Also for me the problem was Cloudflare.
    Deactivating Cloudflare the problem has been resolved.

    Thank You fot your update Frances Allen!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Visual editor suddenly not working’ is closed to new replies.