Support » Plugin: Announcer » Visual Editor still not working

  • aenea

    (@aenea)


    I reported this problem over a year ago but the topic was closed without any response from the developer. The visual editor in this plugin stopped working at the upgrade of WordPress to 3.9.1 and has not worked since.

    I editified the problem as being an incompatability with the way the plugin is calling TinyMCE and the version that is used by WordPress but, alas, no response to this from the developer.

    I have noticed also that when I use Announcer I get the following message in the debug.log file:

    PHP Notice: wp_editor() was called with an argument that is deprecated since version 3.9! TinyMCE editor IDs cannot have brackets.

    which supports my suspicions as to the root of the problem.

    I find this plugin extremely useful but it’s a scunner (to use a good Scots word) to have to code in raw HTML all the time.

    https://wordpress.org/plugins/announcer/

Viewing 4 replies - 1 through 4 (of 4 total)
  • danny1212

    (@danny1212)

    Im having same problem. Have you found anything out?

    aenea

    (@aenea)

    Alas, no. The developer has not responded.

    So this is a bit of a necropost, but I just started using this plugin recently. I just wanted to maybe help out for others looking for a fix for this. Don’t really know where else to put this.

    I’m very very new to wordpress (and php in general) but I think I’ve managed to find a fix. Like 54 of admin/edit_single.php currently shows

    <?php wp_editor( $att['content'], 'atts[content]', array( 'wpautop'=> false, 'textarea_rows'=> 5 )); ?>

    …the problem with that being atts[content] isn’t allowed due to the []’s (as mentioned by @aenea). So, if you change that to

    <?php wp_editor( $att['content'], 'content', array( 'wpautop'=> false, 'textarea_rows'=> 5, 'textarea_name'=> 'atts[content]' )); ?>

    then the visual editor works.

    Hopefully that helps yall out.

    Brilliant! I’d identified that as the line that needed fixing but hadn’t worked out the correct fix. Will make my life so much easier. Many thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Visual Editor still not working’ is closed to new replies.