Support » Fixing WordPress » Visual Editor – same problem as many other people

  • Resolved philgreen

    (@philgreen)


    Over the weekend, when I haven’t changed anything, the visual editor stopped working. When I go to make a post, I can still see the visual/code selector, and visual is highlighted, but I’m looking at the code editor and clicking on the selector makes no effect. It’s the same problem everyone else is having.

    I went to the support forums and found a dozen different answers, all of which I tried. I want to know if I have missed something:

    1. reinstalled wp
    2. checked to see that “use visual editor” was selected
    3. reinstalled tiny mce
    4. put in tiny mce_gzip.php compressor
    5. changed permissions on wp-includes and everything in them to 755
    6. flushed cache many times
    7. turned off all plugins
    8. changed language in the config to “en”

    I did a few other ones that I forgot. Nothing works, what am I missing?

Viewing 10 replies - 1 through 10 (of 10 total)
  • also:

    9. Put a 2 line php.ini in the tinymce folder

    10. reinstalled wp-admin and wp-includes folders from the wordpress zip

    What should I do next?

    Did you try the files from the .tar.gz download? This seemed to work for some too.

    Moderator Andrew Ozz

    (@azaozz)

    WordPress Dev

    Next try to access the tinymce url directly in Firefox and see what comes back. Also what is the first js error as reported by Firebig?

    Thanks masterciw and azaozz! I got the files again from ther tar.gz and used different program than windows zip handler. It seemed to have no effect

    Accessing the tiny_mce URL directly give me a long line of code that starts with “var tinymce={majorVersion:’3′,minorVersion:’1.1′” I think that’s what it’s supposed to give.

    I figured out how to use firebug and it showed me something pretty disturbing:

    1st error is probably nothing:

    dbxGroup is not defined
    [Break on this error] var podPress = new dbxGroup(

    2nd error is:

    missing ; before statement
    var tinymce={majorVersion:’3′,minorVersi… online pharmacy’>buy viagra drugs.

    coming from:

    /wp-includes/js/tinymce/tiny_mce_config.php?ver=20080710

    I fixed that.

    3rd error is:

    tinymce not defined – wp-admin/js/editor.js?ver=20080710

    I put a new wp-config file in, changed encoding in the config to ansi (someone elswhere suggested it), still nothing.

    http://wordpress.org/support/topic/165449?replies=53

    Going through the steps you suggested here.

    Fixed it! I think it was the wp-config and then refreshing and clearing the cache a few times. Thank you!

    It broke again, and I haven’t changed anything at all!

    Hi Phil,

    I had the same problem and it was caused by an extra line break at end of the file functions.php in my theme folder.

    I had recently changed that file however, so I did change something.

    Maybe worth a try though.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Visual Editor – same problem as many other people’ is closed to new replies.