[resolved] Visual Editor Problems with WP 3.5 after upgrading - Local and Remote (3 posts)

  1. alanpae
    Posted 3 years ago #

    I've tried this on a localhost install and on my own web-hosted blog.

    On localhost I disabled all plugins and switched the theme to Twenty-Eleven and it still happens.

    I'm trying to create a simple blog post with two links to online articles.

    Click on Add new.

    For the title use:

    Oracle JDK 7u10 released with new security features

    Click on the text area of the visual editor and Control-V to paste it in. Change it to Heading 3 and then add the link of:


    Go back to the Title and add a semi-colon for the next article and then add:

    Q&A: MacFixIt Answers

    So the title is now:

    Oracle JDK 7u10 released with new security features; Q&A: MacFixIt Answers

    Click on the text area and hit enter twice for spacing and then add the second heading of Q&A: MacFixIt Answers.

    Set the title of this to Heading 3 and add the link of:


    It's a mess. Click on text to switch to the text based editor and view the code.

    This is what the editor returns:

    <h3><a href="https://blogs.oracle.com/henrik/entry/oracle_jdk_7u10_released_with">Oracle JDK 7u10 released with new security features</a></h3>
    <a href="https://blogs.oracle.com/henrik/entry/oracle_jdk_7u10_released_with"> </a>

    <a href="http://reviews.cnet.com/8301-13727_7-57559308-263/q-a-macfixit-answers/?part=rss&subj=news&tag=title">
    <h3>Q&A: MacFixIt Answers</h3>

    Any ideas?

    Worked fine in 3.4.2

    Thanks in advance,

  2. alanpae
    Posted 3 years ago #

    On a single line post things like fine on the visual editor.

    However switching to text reveals:

    <a href="fine">fine

    Which is probably causing multi-line posts to come out really bad.


  3. alanpae
    Posted 3 years ago #

    Fixed in 3.5.1

Topic Closed

This topic has been closed to new replies.

About this Topic