Support » Fixing WordPress » Visual Editor not working with 3.7 update

  • Yesterday I installed the new WP 3.7 at A Traveler’s Library and it screws up the visual editor on my site. (Fortunately my problems are not as serious as other people seem to be having). The public view of the site looks fine.

    On my theme, Blue Grace, there is a gray box that stretches way beyond the borders of my editing box, and does not show the picture that I have entered. In the text version everything appears correct.

    I tried disabling all my plugins and that did not solve the problem.

    I switched to various themes, and the visual editor worked correctly only on Twenty ten, twenty twelve and twenty thirteen of the ones I tried. Some themes showed the gray box, with the picture somewhere within it, some just the gray box.

    I am now reverting to my backup before installing 3.7, but am hoping that I’ll be able to go back to 3.7 at some point.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Where did you download that theme from? Have you asked them about this?

    One user on my site is getting this error with Firefox and IE on Windows. I can’t reproduce creating the problem with Firefox on Mac OS, but I see the problem on the posts she’s created. This is using the Twenty Thirteen theme.

    Check out the end few posts of this forum thread

    Thanks, WPRanger, the people in that thread are talking about my identical problem, and there is a suggestion for a temporary fix. Click on edit, then update (without fixing anything else.)However, that only works until you save the post, and then it reverts to the extra wide gray space with a “lost” picture somewhere in there.
    Apparently a fix for the bug is on the way.

    James Wilson broadcaster


    My problem is when I go to Visual edit the box is completely empty. I happened when I upgraded to 3.7, and was fine before. I changed themes just to see if that resolved the problem but it doesn’t. I was hoped to revert to an older release, but I’m a complete novice

    Moderator kmessinger


    @james Wilson broadcaster

    Please start with your own post.

    I have the same problem with the FuturaPro theme – the gray box that stretches way beyond the borders of my editing box. The image is there if you scroll horizontally and it looks normal in View mode, but it’s tiresome when editing.

    There is a fix which is coming out in 3.7.1, which should be available very soon. Not theme related.

    I encountered this problem with the grey box and horizontal scroll in the visual editor too. Good to hear it’s a bug that about to be fixed. Will wait for the coming update.

    FYI: I had a similar problem and installing the “Use Google Libraries” plugin alleviated some of my issues with the editor and disabling the “WP Editor” plugin I was using fixed the rest of my issues.

    Thanks for the tip. In fact, the bug has been fixed in today’s release 3.71.

    is that 3.71 or do you mean 3.7.1 – as I have 3.7.1 installed and my visual editor is still not working…. any tips on how to fix this would be appreciated…

    the site seems to work well… its just when I want to add a new page or update any pages that the visual editor.. and the kitchen sink.. do not work..

    Same deal with me — All worked fine on last post two weeks ago. Today, Visual tab was grayed out and when clicked upon produced only a blank box. Text tab works and site publishes fine.

    I’ve added no theme (Photocrati) updates or plug-ins between posts. Today, I upgraded to 3.7.1 but the issue continues.

    All help appreciated.


    I had this same problem with the visual editor not showing up.

    I noticed some errors in the javascript console. It looks like something was renamed in reference to tinymce (the visual editor code).

    I had to rename




    and also copy the “en.js” file here:


    Then the editor works again.

    @mitcki, thank you for your response… would it be possible to ask how you renamed them – as in where did you find the file and did you just rename it and save it?

    Im really excited to have this info from you, as I was just going down the path of learning how to uninstall 3.7.1 and go back to 3.7 and start over… this could save me so so so much time… thanks so much,

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Visual Editor not working with 3.7 update’ is closed to new replies.