Support » Plugin: mqTranslate » Visual Editor not working on WP 3.9.1

  • Resolved vertigofactory

    (@vertigofactory)


    Hi there,
    I’ve just upgraded to WP 3.9.1 and to version 2.6.2.6 of mqtranslate and now I can’t use the visual editor Tiny MCE when I try to write posts, custom posts and pages. When I try to switch to Visual it doesn’t work.

    When I disable mqtranslate 2.6.2.6, the visual editor works correctly.

    If it could be useful, I used the Inspector on Chrome to watch what happens into the console when I try to switch to visual mode:

    Uncaught TypeError: Cannot set property 'setup' of undefined post-new.php?post_type=page:845
    
    qtrans_hook_on_tinyMCE post-new.php?post_type=page:845
    
    switchEditors.go post-new.php?post_type=page:925
    
    window.switchEditors.switchto editor.min.js?ver=3.9.1:1
    onclick post-new.php?post_type=page:685

    When the editor page is loaded I see this into the console:

    Uncaught TypeError: Cannot read property 'split' of undefined

    Any ideas? Thank you 🙂

    https://wordpress.org/plugins/mqtranslate/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Also, I noticed that when I write something into the editor and I save, then the content disappear.

    Hi everybody, same problem here:

    Also, I noticed that when I write something into the editor and I save, then the content disappear.

    Same problem with visual editor and 3.9.1. Hope someone can fix this issue.

    Same problem, the content is empty after saving.
    And when I use Advanced Custom Fields AND mqtranslate, there is an error in the console : Uncaught TypeError: Cannot read property 'value' of null.
    I got the javascript error only when I use the both plugin together.

    Hope this help

    WP 3.9.1
    MQTranslate : 2.6.2.6

    Hi everyone,

    I have a similar problem with the built-in visual editor of bbPress.
    When mqTranslate plugin is activated, the visual editor doesn’t show.

    If anyone knows how to solve this, please let me know.

    Thank you.

    WP 3.9.1
    mqTranslate 2.6.2.6
    bbPress 2.5.3

    Thanks Maxim,
    I’m gonna try it right now!

    Mmm doesn’t work for me 🙁

    it doesn’t work for me too 🙁
    anyway, thank you 🙂

    Version of WP and other plugin? Version of browser and your OS
    Deactivate other plugin.
    Maby your theme use conflict js

    I am using:
    – Chrome 35.0.1916.114 on OSX Mavericks
    – WP 3.9.1, mqtranslate 2.6.2.6

    I am NOT using acf-qtranslate 1.3.0 and Advanced Custom Fields 4.3.8. Maybe your fix works well when using these plugins, I don’t know.

    When I deactivate mqtranslate 2.6.2.6 everything works well.

    Hi,

    I also have Problems with the plugin and woocommerce. Visual editor is there in products, but not in product short description. Can’t change there anything – it only shows texteditor and there is no way to change text.

    Worked well in WP 3.9 but not in WP 3.91.
    Please help – I really need to work with my products and need the product short description.

    Thank you
    Irene

    This worked for us.

    Turned on Firefox inspector and for some reason WordPress is looking for the plugin.min.js (/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js) in the root directory, so we just copied it over to the root directory.

    Hope this helps.

    @CreationToday.org: sorry, your fix doesn’t work for me 🙁

    ok ok ok! I found a solution! 🙂

    there’s a bug related to the WPfullscreen deactivation in mqtranslate_javascript.php, so you have just to comment like this (line 253, mqtranslate_javascript.php):

    // Removing WPFullscreen plugin and button
    /*var p = hook.plugins.split(',').filter(function(element) { return (element != 'wpfullscreen'); });
    hook.plugins = p.join(',');
    p = hook.toolbar1.split(',').filter(function(element) { return (element != 'wp_fullscreen'); });
    hook.toolbar1 = p.join(',');*/

    this works for me! 🙂

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Visual Editor not working on WP 3.9.1’ is closed to new replies.