Visual Editor Not Working on Upgrade (45 posts)

  1. Andrew Ozz
    WordPress Dev
    Posted 8 years ago #

    Make sure you access the admin with exactly the same url as set in WordPress and that it's the right one. NS_ERROR_DOM_BAD_DOCUMENT_DOMAIN means that TinyMCE is trying to access some of its files probably from a sub-domain and it takes the path from the setting in WordPress.

    If all this is OK, check your .htaccess file for possible improper redirects. Also look if there are more than one .htaccess in different sub-directories and check them all.

  2. ulipo
    Posted 8 years ago #

    YAY! It worked! the address set in the admin panel contained a capital letter, once removed it, I got back my tynimce!
    Thanks azaozz!

  3. decavolt
    Posted 8 years ago #

    None of the above fixes work with WP 2.5.1

    I've tried:
    - WP_LANG set to "en" instead of ""
    - clear browser cache
    - clear uploads/js_cache/
    - completely delete wp-admin and wp-includes, reinstall
    - completely delete entire WordPress install, reinstall
    - manually install latest version of TinyMCE
    - turn TinyMCE compression off
    - use TinyMCE Advanced plug-in

    Tested with Safari, Firefox on OSX and XP, Firefox and IE on XP

    After each of the above, I still see the following js error when trying to load the editor:
    missing ) after argument list - tiny_mce_config.php line 15

    Then when clicking on the HTML tab in the editor:
    tinyMCE is not defined - editor.js line 82

    Any other ideas?

  4. decavolt
    Posted 8 years ago #

    As an update to my post above - I've downgraded to WP v2.5, tried all the same fixes and testing and still don't have a visual editor.

    At this point, I'm beginning to wonder if it's due to the server environment. This install is running on a remote Linux server running Apache, with PHP 5.1.4.
    I have another Linux server with an identical WP install running Apache with PHP 5.2.5 - the editor works perfectly (tried both WP 2.5.1 and WP 2.5).

    Can anyone else confirm the PHP version they're using when seeing this problem? PHP shouldn't be the culprit, but I'm running out of alternatives.

  5. decavolt
    Posted 8 years ago #

    Another update - this turned out to be a problem with the server.
    If all the fixes in this thread fail, it's likely that realPath is corrupt/malfunctioning in the server's PHP install and/or compression is turned on at the server level and causing problems.

    After moving to a new, much better host, everything worked perfectly right out of the box.

  6. Tardevil
    Posted 8 years ago #

    I have tried every fix in all the forums I can find and nothing works. The visual editor is broken. I can't add pictures. I can't update existing files. Very frustrating. I use godaddy and I wonder if they did something.

  7. Tardevil
    Posted 8 years ago #

    When I open the write page this is what it says at the bottom of the browser. It is not a complete address, because it is cut off at the end. From here I can only use the html writer and upload pictures, but not place them into post. Any help would be great. Thanks

    Downloading picture http://www.blogaboutplants.com/wp_includes/js/tinymce/themes/advanced/skins/wp_theme

    On the write page it says

    Downloading picture http://www.blogaboutplants.com/wp_includes/js/tinymce/themes/advanced/

    or it gets stuck waiting and then says error on page

  8. Tardevil
    Posted 8 years ago #

    It is actually getting hung on waiting for http://www.blogaboutplants.com/wp-admin/post-new.php or page-new.php. I have tried to delete and reload. I have tried to rewrite the whole wp-admin file.

    I get a cursor in the title bar, but not in the writing box. Please advise. Jim

  9. Tardevil
    Posted 8 years ago #

    Fixed. I was using a login page that I had in my favorites. I deleted it and reentered into browser and it works perfect.

  10. Anonymous
    Posted 8 years ago #

    I had this problem, and tried everything suggested above, then noticed that chmod for the following file was 644 instead of 755 wp-includes/js/tinymce/tiny_mce_config.php

    Changed the Permissions, and it now works perfect for me! 8-)

  11. Jupitercow
    Posted 8 years ago #

    The freshpost or fresh page plugin is a problem (version .13). I haven't tried the new one (just came out).

  12. inspired888
    Posted 7 years ago #

    Tried everything suggest here. None of it worked unfortunately.

    I don't even have a js_cache folder -- and I'd love to know why and what that means if I don't have one.

    The I tried the solution from bonheddwr just above here by about two comments.

    I had this problem, and tried everything suggested above, then noticed that chmod for the following file was 644 instead of 755 wp-includes/js/tinymce/tiny_mce_config.php

    This was the answer for me
    THIS WORKED... Nice... which I tried that first.

    Thanks heaps to everyone that has posted their replies to this thread. Team work works.

  13. buscamos
    Posted 7 years ago #

    has anyone tried these fixes on 2.6.2 or 2.6.3? Mine didn't work in 2.3 either, then I upgraded & still doesn't work. suggestions as to which fix?

  14. Jupitercow
    Posted 7 years ago #

    I also noticed that TinyMCE Advanced Plugin can really make a mess if your settings are just slightly off, you have to completely uninstall it and then start over if your visual editor disappears after trying to use it.

  15. curious1960
    Posted 7 years ago #

    Replacing js folder worked for me!

Topic Closed

This topic has been closed to new replies.

About this Topic