Support » Fixing WordPress » Visual Editor not working on 3.1.2

  • Updated to wordpress 3.1.2 on our company website, and since then I have not been able to edit/add pages in the visual editor due to the kitchen sink not displaying buttons…

    http://www.seftonchamber.com is the website for reference.

    wondering if anyone has come accross a similar problem and knows a fix?

    don’t really want to go about re-installing wordpress and last time we had some massive corruption..

    Cheers
    🙂

Viewing 15 replies - 16 through 30 (of 41 total)
  • Still not managed to fix it – any ideas??

    Try changing the theme.
    If it works after changing the theme it suggest a problem in the theme’s functions.php file. Most likely to do with enqueing the jquery script.

    thanks for the post – still not working …

    Moderator kmessinger

    (@kmessinger)

    I also should add, when I try edit a post/page, I don’t see any of the content on the page in the editor, aswell as the kitchen sink….

    This is the classic symptom of a javascript problem, a conflict with jquery, 99% of the time from a outdated plugin. I am very puzzled by this.

    I think you were to try a different computer today. I hope that is the answer.

    I have tried a different computer again just now – and the problem is still persisting… :S

    Was the new computer at work? Have you tried logging in from home?

    It was at work yes, but it was a laptop not connected to the network

    Using the company connection?

    Yes – would this change things?

    It could. You need to try logging on from a machine that is completely independent of your company’s connection or network to rule out any issue being caused by the network/router. I’ve know some company networks strip out all javascript before now for “security reasons”.

    thanks for that – I will try login at home and see what happens then update you tomorrow morning.

    Matt

    I checked this at home and still have the same problem :/

    Did you say you tried a fresh wordpress install? If so it suggests an issue with the webserver. It might be worth taking it up with however manages the webserver.

    It seems really odd that it’s not working as problems with the visual editor often mean a jquery problem which is usually fixed by uninstalling plugins, checking functions.php etc.

    what would I say to the web server? Eg. how would I explain it could be something on their end?

    thanks again

    by the way – we have 2 wordpress websites, and one works and one doesn’t?

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Visual Editor not working on 3.1.2’ is closed to new replies.