WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor not working on 3.1.2

Visual Editor not working on 3.1.2

  • Updated to wordpress 3.1.2 on our company website, and since then I have not been able to edit/add pages in the visual editor due to the kitchen sink not displaying buttons…

    http://www.seftonchamber.com is the website for reference.

    wondering if anyone has come accross a similar problem and knows a fix?

    don’t really want to go about re-installing wordpress and last time we had some massive corruption..

    Cheers
    🙂

Viewing 15 replies - 1 through 15 (of 41 total)
  • Moderator kmessinger

    @kmessinger

    Disable all plugins and switch to the twentyten theme. Add all back one at a time until it breaks.

    Most of the time it is a plugin.

    Hi Kmessinger – thanks for your post.

    Have tried that and unfortunately had no result 🙁

    Moderator kmessinger

    @kmessinger

    Check to make sure java is working correctly, http://www.java.com/en/download/installed.jsp

    Have you tried a different browser?

    thanks again – just updated my JS and the problem is still there – have tried google chrome, firefox and IE

    Moderator kmessinger

    @kmessinger

    Delete the entire wp-admin and wp-includes folder. Upload a new set of directories and files to replace these from a fresh copy of wp.

    Also, how about a simple reboot?

    Could you please advise the best way of doing this? last time I messed it up! Tried a reboot too..

    Moderator kmessinger

    @kmessinger

    The easiest way is to log in to your hosted account, go to file manager and bring up your files. Delete the wp-admin and wp-includes folders/directories. DO NOT touch the wp-content folder or the wp-config file that is in the root.

    FTP, using filezilla or whatever you are familiar with, the new directories to your hosted account. If you are unfamiliar with ftp try sending a couple of test files before deleting anything.

    thnks for that – just done what you suggested and it’s not worked 🙁

    esmi

    @esmi

    Forum Moderator

    Have you tried using another browser? Or another machine?

    yes – tried Chrome, IE and firefox, not tried another machine yet – will do so on Monday

    Excuse me for asking, but do you see your profile (/wp-admin/profile.php) ?

    There is option “Disable the visual editor when writing”. If it checked – clean it.

    Hi,

    I have the same problem but no solution.
    Only superadmin sees the buttons of the visual editor.

    esmi

    @esmi

    Forum Moderator

    @matt Dunn: are you behind a corporate firewall, by any chance?

    @monpelaud: It is considered impolite to interrupt another poster’s thread. Please post a new topic.

    Thanks for replies guys, just got back to work so am back working on the problem.

    Kvisaz, I have checked my profile and that button isn’t checked,

    Esmi, I’m not behind a corporate firewall – It’s a smallish company I work for with standard security…

    I also should add, when I try edit a post/page, I don’t see any of the content on the page in the editor, aswell as the kitchen sink….

    I really need this fixing asap – any more tips please guys? You’re all a great help

    Matt

    Have just tried deleting the WP-includes and WP-admin files, and re-uploading from a fresh install of WP again and had no luck – strange!!

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Visual Editor not working on 3.1.2’ is closed to new replies.
Skip to toolbar