Support » Fixing WordPress » Visual Editor Not Working on *1* Post

  • Resolved BitchSpot


    Actually using 2.9.2 now, but not an option.

    Earlier today, one of my pages stopped allowing the Visual editor to be used. It is still fine on all the rest of the pages and since all pages are basically variants of each other, I don’t think it’s a matter of coding. I went looking for other people who have problems and while it seems to be rather common, it seems to be that either the editor works or it doesn’t, it isn’t page-specific.

    I upgraded to 2.9.2 and that didn’t solve the problem. I have disabled all plugins, that didn’t help. I switched to the default theme, that didn’t fix it. I cleared cookies and cache. Nothing. The “disable visual editor” isn’t checked. I upgraded my theme to the most recent version. No go. I modified the wp-config.php as suggested and that didn’t do it either. I installed a new editor (Dean’s FCKEditor) and that didn’t work on that particular page. It’s only this one particular page, all the others work.

    Any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi


    Forum Moderator

    Sounds like the problem is in the post/page itself. Link?

    It started to affect other pages too, it was progressive. One page after another failed so I ended up killing the installation and reinstalling fresh. Now, it works, I just lost a year’s worth of content when every backup turned out to be corrupt.

    What fun.

    Thanks for your help.

    We were having a similar problem. For us the solution we found was the same as ohbrooke on this page. However we did not use the delete-revision plugin but simply recreated the page and copy/pasted the content to the new page, effectively creating an identical page minus revisions.

    There seems to be a limit to the number that WordPress can store, and when you reach that limit then the edit page will not load completely. The telltale sign that this is the case is that you will not see a WordPress footer on the edit page.

    My footer does not work on I’m currently using WP 010 with plug-ins by WP Spider. The same problem was happening on Thesis Theme and thought changing to new theme would help. I’ve been looking to change theme anyway.

    Would this be a php or css error? My footer php looks like its all encrypted.


    I found a solution and i think I have uncovered the problem.

    I too experienced the loss of the visual editor, and having tried a number of the suggested fixes, none of which worked, I backed up my data and deleted the whole installation including the database off the server and reinstalled everything. However the problem still remained. I was using MS Internet explorer as my browser.

    Furtunately I have another machine on the same network and by way of a test I logged into my WordPress blog, again using MS IE as my browser. Spookily the visual editor was there and working fine. I did some initial checks between the two browsers to check the set up and addons installed and as yet I have not uncovered any differences but I know its there somewhere.

    I then went back to my original machine and logged into the blog using Firefox as my browser and bingo the Visual editor was there working fine. I then logged out went back to MSIE logged in again and the Visula editor was not there…… so my explanation is that its a browser problem, there must be a difference between my two MSIE browser setups on my two machines as one works and one does not, and on the machine it doesnt work on if i use Firefox the Visual editor is there!

    I am no techie but I am still looking at both MSIE setups to see if there is an obvious or not so obvious reason why one works and one does not.

    Can I suggest anyone who has this problem tries a different browser and see if the VE reappears using Firefox or Opera?

    If i do find the MSIE difference i will repost my findings.

    Add this to your wp-config file:

    define (‘CONCATENATE_SCRIPTS’, false);

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Visual Editor Not Working on *1* Post’ is closed to new replies.