Visual Editor Not Working - No Toolbar, Can't Insert Media (4 posts)

  1. obsessedwithfilm
    Posted 3 years ago #


    I've just upgraded to WP 3.5 from 3.4.2 and have the following issues:

    -When editing a post, the visual tab doesn't go anywhere, it's there, I can click it, but it doesn't load any changes.

    -I can click "Add Media", it'll pop the media manager (which is a beautiful improvement), I can upload a file, it'll show up correctly, but when I click "Insert Into Post" nothing happens, but it returns me to the line in the post where I was editing, but no code.

    -There's no tool box at the top of the edit post area. Usually there's a variety of tools (at least there was previously), was this lost in the new version or is this also broken from my installation?

    Troubleshooting steps I've taken:

    - Disabled *all* plugins
    - Activated Twenty Twelve theme
    - Manually removed wp-admin and wp-includes folders and re-uploaded from the WordPress 3.5 zip package on wordpress.org.

    Server is running Nginx with Varnish. I have cleared the varnish cache since upgrading.

  2. obsessedwithfilm
    Posted 3 years ago #

    Javascript Error Console in Chrome reports the following:

    Uncaught TypeError: Cannot call method 'add' of undefined

  3. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Can you try another browser to look for Javascript errors?

  4. dallasm
    Posted 3 years ago #

    Thanks obsessedwithfilm, I've spent an hour working on this problem with no luck! My server is running varnish and restarting it fixed it for me.

    I've also tried adding define(‘SCRIPT_DEBUG’, true ); define(‘CONCATENATE_SCRIPTS’, false ); into the wp-config.php file as per this thread http://wordpress.org/support/topic/visual-editor-is-not-running-in-wordpress-35-for-my-weblog?replies=13 which had helped a lot of people, and of course resetting plugins and themes to default.

    Not many people have varnish, so your comment twigged the solution for me
    Hope you solve yours!

Topic Closed

This topic has been closed to new replies.

About this Topic